Catalyst 4500 series switch

Unanswered Question
Apr 10th, 2008
User Badges:

Hello,

I am new to Multilayer switching (Catalyst 4510 series) and I want to configure my Catalyst 4510 switch to have Inter-VLAN communication. Can somebody please guide me or point me to the exact configuration for Inter-VLAN routing. Thank you for your help.


-chie

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Istvan_Rabai Thu, 04/10/2008 - 20:26
User Badges:
  • Gold, 750 points or more

Hi Narciso,


A simple example of configuring a switch with 3 vlans and intervlan routing:


[enable ip routing]

ip routing


[configure the vlans]

vlan 2

exit

vlan 3

exit

vlan 4

exit


[configure the vlan interfaces]

interface vlan 2

ip address 10.2.0.0 255.255.0.0

interface vlan 3

ip address 10.3.0.0 255.255.0.0

interface vlan 2

ip address 10.4.0.0 255.255.0.0



[configure access ports in the vlans]

interface range fa1/0 - 15

switchport

switchport access vlan 2

switchport mode access


interface range fa2/0 - 15

switchport

switchport access vlan 3

switchport mode access


interface range fa3/0 - 15

switchport

switchport access vlan 4

switchport mode access


For this to work, you don't have to configure a routing protocol, as routing will take place between the vlan interfaces by default.


If you need more help in configuring other features, like you have more switches, more vlans, you need to configure routing protocols, access-lists etc., just write me and I will help you.



Cheers:

Istvan


lazon Fri, 04/11/2008 - 13:11
User Badges:

Istvan,


Thanks a lot for your response, now it will give a better understanding about Inter-VLAn routing.


-Narciso

lazon Fri, 04/11/2008 - 13:19
User Badges:

Hello again,


I presume that this configuration applies to any Multilayer switch model? Thanks again.


Istvan_Rabai Sat, 04/12/2008 - 02:28
User Badges:
  • Gold, 750 points or more

Hi Narciso,


Yes, this config is general enough to be applied in any Cisco multilayer switch.


Cheers:

Istvan

lazon Sat, 04/12/2008 - 17:51
User Badges:

Hi Istvan,


What is the exact connection if you have a PIX firewall in place? Is it like this Internet--Router---PIX---Core Switch---Access layer switch. If this is the case from the core switch what will be your default gateway? Is Inter-VLAN communication be affected? Thanks again.


Regards,

Narciso


Istvan_Rabai Sat, 04/12/2008 - 22:48
User Badges:
  • Gold, 750 points or more

Hi Narciso,


This can be a suitable connection order.


The default gateway should be the multilayer switch (or router) that is closest to the access layer hosts.


In this case probably the Core Switch, which should operate in layer3 mode, where the Access layer switches are a layer2 switches.


Inter-vlan communication is generally not affected. The Core Switch should be able to manage it independently of the presence of the firewall and the Internet-router.


Cheers:

Istvan

Actions

This Discussion