UC520 BRI Connection

Answered Question
Apr 11th, 2008
User Badges:

I have a new single site setup using UC520. 2 BRI ports are connecting to PSTN. I cannot get BRI work. 'debug isdn q931' shows calls are rejected even if when no calls are made. Please help me understand the debug messages. Debugs are attached. Configurations are as follows:


relavant configurations: ephone-dn are numbered from 1000--1009. 111 is the local emergency number

-----------------------------------

!

trunk group PSTN_OUT

description All Analogue PSTN Interfaces

translation-profile outgoing STRIP_1_OUTGOING

!

voice translation-rule 8000

rule 1 /^111$/ /111/

rule 2 /^1/ //

!

voice translation-rule 8001

rule 1 /^.*\(..\)$/ /10\1/

!

!

voice translation-profile DID_TO_EXT

translate called 8001

!

!

voice translation-profile STRIP_1_OUTGOING

translate calling 1111

translate called 8000

!

interface BRI0/1/0

no ip address

no logging event link-status

isdn switch-type basic-5ess

isdn timer T321 0

isdn point-to-point-setup

isdn incoming-voice voice

isdn map address .* plan national type unknown

isdn send-alerting

isdn sending-complete

trunk-group PSTN_OUT

!

interface BRI0/1/1

no ip address

no logging event link-status

isdn switch-type basic-5ess

isdn timer T321 0

isdn point-to-point-setup

isdn incoming-voice voice

isdn map address .* plan national type unknown

isdn send-alerting

isdn sending-complete

trunk-group PSTN_OUT

!

voice-port 0/1/0

translation-profile incoming DID_TO_EXT

translation-profile outgoing STRIP_1_OUTGOING

output attenuation 3

compand-type a-law

cptone NZ

bearer-cap Speech

!

voice-port 0/1/1

translation-profile incoming DID_TO_EXT

translation-profile outgoing STRIP_1_OUTGOING

output attenuation 3

compand-type a-law

cptone NZ

bearer-cap Speech

!

!

dial-peer voice 50 pots

destination-pattern .T

direct-inward-dial

port 0/1/0

no sip-register

!

dial-peer voice 51 pots

destination-pattern .T

direct-inward-dial

port 0/1/1

no sip-register

!

---------------------------------


Thanks in advance.






Correct Answer by paolo bevilacqua about 9 years 2 months ago

Hi, it is normal that layer 1 and 2 go down after a timeout. Router or switch will reestablish them as soon there's an active call. Also, which image are you using? You should have XW6 for the UC520.


For the extensions, you can either use an incoming rule like


rule 1 // /1/


or


dialplan-pattern 1 pattern ... extension-length 4 extension-pattern 1...


Hope this helps, please rate post if it does!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
paolo bevilacqua Fri, 04/11/2008 - 10:52
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


please configure "isdn static-tei 0" under bri interfaces. Then you can use the trunk-group referencing it instead of port under DP.


Then you can optimize the translation-rules if needed, an alternative is to use "dialplan-pattern" under telephony-service.

In any case when you have rules under trunk group, you don;t need them under voice-port.


Note you don't need:

isdn timer T321 0

isdn send-alerting


Hope this helps, please rate post if it does!



paolo bevilacqua Fri, 04/11/2008 - 19:48
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

I had not seen catched that before, for outgoing, please configure isdn switchtype basic-net3.


For incoming, how do you extensions numbers looks like ?


Chuan Liu Fri, 04/11/2008 - 19:54
User Badges:

Hi,


When I change the switch type to basic-net3, bri interface layer 2 and 3 are not up. I am using the only type that can bring up all layer 3 on the interface.


Extention number are 1000, 1002,..., 1021.


Thanks

Correct Answer
paolo bevilacqua Fri, 04/11/2008 - 20:16
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, it is normal that layer 1 and 2 go down after a timeout. Router or switch will reestablish them as soon there's an active call. Also, which image are you using? You should have XW6 for the UC520.


For the extensions, you can either use an incoming rule like


rule 1 // /1/


or


dialplan-pattern 1 pattern ... extension-length 4 extension-pattern 1...


Hope this helps, please rate post if it does!

Chuan Liu Fri, 04/11/2008 - 21:33
User Badges:

Hi,


You are great!

It starts working now.

Millions of thanks.

paolo bevilacqua Fri, 04/11/2008 - 21:43
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Thanks for the nice rating and good luck!

Actions

This Discussion