Call Transfer after TCL-AA

Unanswered Question
Apr 12th, 2008
User Badges:

I have CME 4.2 Version 12.4(11)XW6

TCL version is 2.1.2.2

Telepone images 8-2-2SR2


Problem is as follows;

Outside call is answered by tcl and transferred to OPERATOR

OPERATOR answers,

Press TRANSFER,

Dials EXTENSION,

Press TRANSFER again,

!!! It takes 4-5 seconds to complete the transfer. By this time Calling party appears to be HOLD and Transferred party appears to be ringing on the OPERATOR telephone !!!


I try different telephones (796x, 794x, 791x) and earlier versions than 8-2-2SR2

Nothing change.


If I disable TCL-AA, problem dissapears.



application

service queue flash:app-b-acd-2.1.2.2.tcl

param queue-len 10

param aa-hunt1 300

param aa-hunt2 302

param queue-manager-debugs 1

param number-of-hunt-grps 2

!

service aa flash:app-b-acd-aa-2.1.2.2.tcl

paramspace english index 1

param number-of-hunt-grps 2

param handoff-string aa

param dial-by-extension-option 5

paramspace english language en

param max-time-vm-retry 2

param aa-pilot 8005550123

paramspace english location flash:

param second-greeting-time 60

param call-retry-timer 15

param max-time-call-retry 600

param voice-mail 5000

param service-name queue


dial-peer voice 222 voip

service aa

destination-pattern 8005550123

session target ipv4:10.10.10.10

incoming called-number 8005550123

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad





  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Sat, 04/12/2008 - 08:50
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Not sure if would help, but can you try 8.2.2 SR4S ?

recep.sefer Sat, 04/12/2008 - 10:14
User Badges:

I change fw 8.2.2 SR4S

Nothing changes,

This is not releted with TCL version

I try 2.1.0.0,

Problem continues

When I disabel TCL, problem dissapears

What else can I try?


THANKS.

paolo bevilacqua Sat, 04/12/2008 - 10:25
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

One more thing, try appending # after entering extension, beside that I'm afraid you might need to get the tac to reproduce and file a bug (unless one already exists). Good luck!

Hi


I've seen the exact problem with every CME we have deployed using 12.11.XJ or later.


We raised a TAC case but Cisco TAC refuse to identify it as a bug, they called it feature change.


Basically Cisco have broken the H.323 standards based supplementary services feature that are used to with transfer can call-forwarding.


The workaround is to disable these services, but it has some minor short coming if you use gatekeepers for on net calls (toll bypass).


I believe that by adding the following should resolve your issue;


voice service voip

no supplementary-service h450.2

no supplementary-service h450.3



If you can log a TAC case to help get this problem identified as a bug, contact me directly and I will provide you the existing service reference number. Maybe if more people log it as an issue it might be resolved.


I hope this helps,


Regards,


Mike.

Actions

This Discussion