Problem installing SDM on 877

Unanswered Question
Apr 12th, 2008

Installation starts ok and copies files to the router and then it stops copying and the setup still says that it is copying and it will stay like that foreever until I kill the copying process.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Mark Yeates Sat, 04/12/2008 - 13:15

Stephane,

Do you by chance have A firewall running on the PC that you are trying to install SDM with? If so I would disable it temporarily while you install SDM.

If that doesn't work Install the SDM launcher on your PC and run it from there, and then you can install SDM on the router using the locally installed copy of SDM.

http://www.cisco.com/en/US/products/sw/secursw/ps5318/prod_installation_guide09186a00803e4727.html#wp65518

Mark

stephane.ricard Sat, 04/12/2008 - 13:27

Thanks Mark.

I did check that before posting and it is disabled. Using Vista + IE7.

I tried that too... When I launched it using SDM Launcher from the PC, I get a window that pops up with the source of runAPP.shtml, that is as far as it goes...

Not having much luck... :-(

I am with SDM V2.5

I am just trying to get going with setting it up for PPoE, DHCP Server, NAT and later QoS to fix my problem with choppy VoIP conversation when my upload is saturated.

Thanks

Stephane

Mark Yeates Sat, 04/12/2008 - 13:48

Stephane,

Here are the steps to fix that problem!

1. Ensure that you have Java installed. http://www.java.com

2. Install the latest Cisco SDM from Cisco

3. Open Internet Explorer, Tools -> Internet Options. Click the Advanced Tab. Scroll down to the “Security” Section. Make sure that “Allow active content to run in files on My Computer” is checked.

http://blog.montopolis.com/index.php/2008/02/29/cisco-sdm-on-vista-not-working/

Good Luck!

Mark

stephane.ricard Sat, 04/12/2008 - 14:28

I now get this:

SDM Startup Error

SDM has not been granted with the necessary privileges in order to startup successfully, or another unknown error occurred during startup.Please close all involved browser windows and try again by granting all requested privileges.

I tried googling on that error and someone pointed out ip http auth local. It is set. dunno what to do next...

Thanks for your help..

Stephane

Mark Yeates Sat, 04/12/2008 - 14:54

Is that error message from the installation or from when you are trying to run SDM? I am not familiar with that error. Please ensure the commands below link are input into your router, and you have a username/password with a privilege level of 15.

Router(config)# ip http server

Router(config)# ip http secure-server

Router(config)# ip http authentication local

Router(config)# username privilege 15 password 0

Router(config)# line vty 0 4

Router(config-line)# privilege level 15

Router(config-line)# login local

Router(config-line)# transport input telnet

Router(config-line)# transport input telnet ssh

http://www.cisco.com/en/US/docs/routers/access/cisco_router_and_security_device_manager/software/quick/guide/SDMq7.html#wp44788

Hope this helps!

Mark

stephane.ricard Sat, 04/12/2008 - 15:13

I got it to work finally. It seems that the install under Vista does not really work and stalls half way down copying files to the Router. I launched the install from an XP workstation and it worked. All files were copied. I have SDM launched now so on withthe config!!! Youhou!

Thanks for your valuable help! Much appreciated.

Regards,

Stephane

Anonymous (not verified) Sat, 04/12/2008 - 21:04

Actions

This Discussion