PPP and HDLC..........!

Unanswered Question
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Sat, 04/12/2008 - 19:24

gaurav

If the links are HDLC then there is not any way to bundle them into a single logical entity. For PPP links it may be possible to use ppp multilink to bundle multiple links into a single logical entity. But without knowing how the links are used in MPLD it is hard to know whether multilink would be appropriate.

HTH

Rick

Rick, thanks for the reply. I have made a dummy config, just want you to veryfy if it is doable or not.

interface Serial0/0:1

no ip address

encapsulation ppp

ppp multilink

multilink-group 1

interface Serial0/1:1

no ip address

encapsulation ppp

ppp multilink

multilink-group 1

interface Multilink1

ip address 172.20.122.22 255.255.255.252

ppp multilink

multilink-group 1

interface Tunnel0

bandwidth 1544000

ip address 192.168.1.6 255.255.255.252

load-interval 30

Keepalive 10 3

tunnel source 172.20.122.22

tunnel destination 172.22.154.118

The tunnel interface at other side will have config like:

interface Tunnel0

bandwidth 1544000

ip address 192.168.1.5 255.255.255.252

load-interval 30

Keepalive 10 3

tunnel source 172.22.154.118

tunnel destination 172.20.122.22

Moreover, >>But without knowing how the links are used in MPLD it is hard to know whether multilink would be appropriate>>

What exactly you want to know abt how the links are used in MPLS?

thanks and regards,

--gaurav

Richard Burts Sat, 04/12/2008 - 19:53

gaurav

I am not clear why you would run a GRE tunnel with its source and destination as the end point of the multipoint link. But if you want to do it this config looks reasonable - assuming that the router on the other end also has 2 serial links configured as part of the multilink bundle similar to what the first router has.

HTH

Rick

lamav Sat, 04/12/2008 - 20:01

Gaurav:

I haven't configured MLP in a while, plus I just got home from a lounge, so I am a bit plastered (lol), but if I recall correctly, you do not need the multilink-group 1 command line under the Multilink interface itself. The "1" in interface Multilink 1 is the group number that binds the physical interfaces to the Multilink virtual interface.

Other than that, it looks good to me. But you should search Cisco's website to be sure. I am sure there arre plenty of examples of how to configure MLP.

Thanks

HTH

Victor

OH, alright. I'll do that, Victor.

Rick, victor

Unfortunately I do not have same, two serial interfaces at the other end of the tunnel. There I have a DS3/T3 interface, I'm planning to have subinterfaces created and then the tunnel interface with respective BW, source IP and destination IP. why I'm creating subinterface is because the DS3/T3 interface will provide BW to three remote sites.......

Is it OK what I'm planning to do......!

--gaurav

Richard Burts Sun, 04/13/2008 - 10:53

gaurav

I understand having subinterfaces on the DS3 and why you do this. I do not understand running the GRE tunnel over the multilink.

To have PPP multilink work on your end there must also be functioning multilink on the other end. You are getting into an aspect that I have never done myself and have not seen done, which is to run PPP multilink on a group of channels within a DS3. It may be ok and work just fine.

HTH

Rick

Actions

This Discussion