FAX Connetc to FXS port of UC520

Answered Question
Apr 13th, 2008

Hi,

How to assign an extention # to the FXS port that connects a fax machine? I have a dial-peer enabled with 'stcapp', but it does not accept a 'destination-pattern' command.

voice-port 0/0/0

!

dial-peer voice 1 pots

service stcapp

port 0/0/0

!

Thanks in advance.

I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 8 years 7 months ago

Hi, when saying wic, the whole slot is actually being referenced, so you're fine with the commands you entered.

Now, if you used the dialplan-pattern command to received did calls, that doesn't cover non-ephone DP, so you need either to use the translation-rule as we discussed before, or do the complete config for "fxs port in sccp mode". This way you end creating an ephone-dn for the fxs port.

I find the first option to be simpler, on the other hand you might need the second option anyway.. the choice is your!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Paolo Bevilacqua Sun, 04/13/2008 - 01:34

Hi,

you don't really need stcapp for a fax machine.

That is used for analog phone to give them features like dual lne, transfer etc. Just remove stcapp and place the destination-pattern instead.

Make sure you have the network-clock-participate and select commands else your faxes might fail.

Chuan Liu Sun, 04/13/2008 - 01:55

Hi Paolo,

Thanks again.

This UC520 has 4 wic, but I can enable only 2 for network-clock-participate: the 2 BRI cards. When use the above command for the other 2 wic id, error message saying 'WIC slot is empty or does not support clock participate'.

As you expect, I cannot get a fax tone when I dial the number. What is wrong?

Correct Answer
Paolo Bevilacqua Sun, 04/13/2008 - 04:51

Hi, when saying wic, the whole slot is actually being referenced, so you're fine with the commands you entered.

Now, if you used the dialplan-pattern command to received did calls, that doesn't cover non-ephone DP, so you need either to use the translation-rule as we discussed before, or do the complete config for "fxs port in sccp mode". This way you end creating an ephone-dn for the fxs port.

I find the first option to be simpler, on the other hand you might need the second option anyway.. the choice is your!

Chuan Liu Sun, 04/13/2008 - 10:55

Hi Paolo,

Thanks. I am very impressed by your dedication to answering and solving problems even on Sunday night.

I am using translation-rule instead of dialplan-pattern. I followed the 'DTMF Relay, Fax Relay and Modem Relay for SCCP FXS Ports in Cisco IOS'. When 'show voice dsp' and 'show voice call summ', no 'fax' codec was shown as the example in the doc. Instead 'g711ulaw' appeared when I called the fax number. But most importantly, I successfully sent a fax to the machine.

I am new in VoIP. Thank you very much for your help.

Paolo Bevilacqua Sun, 04/13/2008 - 12:49

Oh, no worry, today I fixed a little my car (not really much fixed yet) and you fixed the cme.

You configured properly. What cme does in that case, when it finds the call is terminated on a pots port, can hairpin. No actual codec involved.

But, this way you could have ephones/fax located virtually everywhere as direct cme extension and it would fax or modem relay so it to make it work over IP. Then if you didn't, place network-clock-select for the two ports even w/ different priorities.

You will find that fine tuning a cme takes time, but it comes out a proper system.

Thanks again for nice rating!

Actions

This Discussion