%DUAL-5-NBRCHANGE message

Unanswered Question
Apr 14th, 2008


I have 3 routers connected via FR ( hub and spoke topology, R2-hub, R1 and R3 are spokes). I see error message at R3 -

%DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.123.1 (Serial0/0/1) is down: retry limit exceeded


Which reason of that message can be and where search mistake?



=========================

R1

====

!

interface Serial0/0

ip address 183.1.123.1 255.255.255.0

encapsulation frame-relay

frame-relay map ip 183.1.123.2 102 broadcast

frame-relay map ip 183.1.123.3 102

no frame-relay inverse-arp

!

router eigrp 100

network 150.1.1.1 0.0.0.0

network 183.1.17.1 0.0.0.0

network 183.1.123.1 0.0.0.0

no auto-summary

eigrp router-id 150.1.1.1

!



Rack1R1#sh ip eigrp ne

IP-EIGRP neighbors for process 100

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

1 183.1.17.7 Fa0/0 11 14:10:45 616 3696 0 13

0 183.1.123.2 Se0/0 156 14:15:12 49 294 0 37



=========================

R2

====

!

interface Serial0/0

ip address 183.1.123.2 255.255.255.0

encapsulation frame-relay

no ip split-horizon eigrp 100

no fair-queue

frame-relay map ip 183.1.123.1 201 broadcast

frame-relay map ip 183.1.123.3 203 broadcast

no frame-relay inverse-arp

!

router eigrp 100

network 150.1.2.2 0.0.0.0

network 183.1.28.2 0.0.0.0

network 183.1.123.2 0.0.0.0

no auto-summary

eigrp router-id 150.1.2.2

!




Rack1R2#sh ip eigrp ne

IP-EIGRP neighbors for process 100

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

2 183.1.123.3 Se0/0 153 14:15:45 48 288 0 208

1 183.1.123.1 Se0/0 135 14:16:54 49 294 0 24

0 183.1.28.8 Fa0/0 13 14:24:26 12 200 0 20


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
rmv72 Mon, 04/14/2008 - 00:51

=========================

R3

====

!

interface Serial0/0/0

ip address 183.1.0.3 255.255.255.0

encapsulation frame-relay

ip ospf network broadcast

ip ospf dead-interval minimal hello-multiplier 3

ip ospf priority 0

clockrate 2000000

frame-relay map ip 183.1.0.4 304

frame-relay map ip 183.1.0.5 304 broadcast

no frame-relay inverse-arp

!



!

router eigrp 100

redistribute connected metric 10000 100 255 1 1500 route-map VLAN33

network 150.1.3.3 0.0.0.0

network 183.1.123.3 0.0.0.0

no auto-summary

eigrp router-id 150.1.3.3

!



================================



Rack1R3# sh ip eigrp ne

IP-EIGRP neighbors for process 100

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 183.1.123.2 Se0/0/1 134 13:59:32 50 300 0 37

Rack1R3#

*Apr 14 07:29:07.575: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.123.1 (Serial0/0/1) is up: new adjacency

Rack1R3#

*Apr 14 07:32:12.087: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.123.1 (Serial0/0/1) is down: retry limit exceeded

Rack1R3#

*Apr 14 07:32:53.659: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.123.1 (Serial0/0/1) is up: new adjacency

Rack1R3#

*Apr 14 07:35:58.175: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.123.1 (Serial0/0/1) is down: retry limit exceeded

Rack1R3#

*Apr 14 07:36:25.239: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.123.1 (Serial0/0/1) is up: new adjacency

Rack1R3#

*Apr 14 07:39:29.751: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.123.1 (Serial0/0/1) is down: retry limit exceeded

Rack1R3#

*Apr 14 07:40:10.123: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.123.1 (Serial0/0/1) is up: new adjacency

Rack1R3#

Rack1R3#

Rack1R3#

Rack1R3# sh ip eigrp ne

IP-EIGRP neighbors for process 100

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

1 183.1.123.1 Se0/0/1 167 00:01:07 1 5000 1 0

0 183.1.123.2 Se0/0/1 166 14:12:06 50 300 0 37

Rack1R3#

rmv72 Mon, 04/14/2008 - 01:25

Rack1R3#ping 224.0.0.10


Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.10, timeout is 2 seconds:


Reply to request 0 from 150.1.3.3, 1 ms

Reply to request 0 from 183.1.123.2, 88 ms


I don't have reply from 183.1.123.1 ( R1)



But if i do it from 183.1.123.1 i have reply from R2 and R3=

Rack1R1#ping 224.0.0.10


Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.10, timeout is 2 seconds:


Reply to request 0 from 183.1.17.7, 1 ms

Reply to request 0 from 183.1.123.3, 180 ms

Reply to request 0 from 183.1.123.2, 140 ms

Reply to request 0 from 183.1.123.2, 128 ms

Reply to request 0 from 150.1.1.1, 1 ms


Istvan_Rabai Mon, 04/14/2008 - 09:56

Hi Mike,


For the configuration to work you don't need to configure frame-relay mapping between the spoke routers R1 and R3:


R1

====

!

interface Serial0/0

ip address 183.1.123.1 255.255.255.0

encapsulation frame-relay

frame-relay map ip 183.1.123.2 102 broadcast

frame-relay map ip 183.1.123.3 102 - this mapping is not needed (on R3 not needed either).

no frame-relay inverse-arp


You probably have the symmetrical config on R3, but it is not required either.


The spoke routers each need to build up the neighbor relationship with the hub router R2 but not between the spoke routers R1 - R3.


Remove these frame-relay map commands.

Routers R1 and R3 will learn each other's routes through R2 anyway, due to the "no ip split-horizon eigrp 100" command that you applied rightly on R2.


Cheers:

Istvan




rmv72 Tue, 04/15/2008 - 01:26

Hi Istvan!

But without that mapping i don't have connectivity between R1 and R3.

rmv72 Tue, 04/15/2008 - 01:35

Several words from theory-

From the output of the show command, the SRTT is at 0 ms, the retransmission timeout (RTO) timer is at 5000 ms, and the Q count is at 4 and is not decrementing. These three numbers give the biggest clue that this is a unidirectional link problem. The following is the meaning of SRTT, RTO, and Q count:


*


Smooth round-trip time (SRTT)-The number of milliseconds it takes for an EIGRP packet to be sent to this neighbor and for the local router to receive an acknowledgment of that packet

*


Retransmission timeout (RTO), in milliseconds-The amount of time that the software waits before retransmitting a packet from the retransmission queue to a neighbor

*


Q count-The number of EIGRP packets (Update, Query, and Reply) that the software is waiting to send


Referring to Example 7-1, the fact that the SRTT timer is 0 indicates that no acknowledge-ment packets are being received. The Q count is not decrementing, which indicates that the router is trying to send EIGRP packets but no acknowledgement is being received. RTR B will retry 16 times to resend the packet; eventually, RTR B will reset the neighbor relationship with the log indicating RETRY LIMIT EXCEEDED, and the process starts again. Also, keep in mind that the 16 times retransmission of the same packet is done using unicast, not multicast. Therefore, the RETRY LIMIT EXCEEDED message indicates a problem with transmitting unicast packets over the link, and this is most likely a Layer 1 or Layer 2 problem.


The solution to this problem is to troubleshoot from a Layer 2 perspective. In this example, a call to the WAN provider is needed to find out why the circuit from RTR B to RTR A is broken. After the link between RTR B to RTR A is fixed, the problem will be resolved.

--------------

In my case i can ping R1 from R3. Strange things.




Istvan_Rabai Tue, 04/15/2008 - 11:20

Hi Mike,


As I mentioned, you don't need direct connectivity between R1 and R3. They should be reachable for each other through R2, the hub router.


You should be able to ping between R1 and R3.


Please remove those mappings and post me the show ip routes from all three routers so I can see what happened.


Thanks:

Istvan


Actions

This Discussion