"crypto pki" CLI command

Unanswered Question
Apr 14th, 2008

Hello all!

I have Cisco 1721 router (without MOD1700-VPN) which I intend to use for VPN connection.I received the config for a third-party service partner and also the IOS version that I should use.The problem is that at some point I have to issue:

"crypto pki.." command under CLI, and this command is not available.I tried more than one IOS (feature set: IP PLUS IPSEC 3DES, ENTEPRISE BASE, and some more) and this command is not available.I could not try IOS from "ADVANCE..." feature set, because of the lack of space on flash.I need the "Advance ..." IOS version? Can somebody give me a hint please?


Have a nice day!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
srue Mon, 04/14/2008 - 11:16

see if your IOS supports the "crypto ca..." commands. "crypto pki.." replaced "crypto ca..." in 12.3(7)T. ie, if your IOS is older than 12.3(7)T, you will need to use crypto ca.

Calin Chiorean Mon, 04/14/2008 - 22:22

Hi and thanks for answer.I used 12.3(12)E for "advanced security" and "enteprise base".The rest IOS images are older than 12.3(7)T, but I think that "advanced security" IOS should had support this command.

I will try to find for the "IP plus ipsec 3des" a newer version to try.




This Discussion