877 router and VoIP - no audio

Unanswered Question
Apr 14th, 2008

I am having a hard time getting VoIP to work. I have a PBX using an IP trunk that is accessed over NAT.

I did port forwarding on UDP 5060 to my internal address. I can make calles but no audio. Whay is happening is that the RTP streams are assigned dynamically when the call is created. i can see the NAT translations outgoing but i don't think it is coming back in.

I tried doing

ip inspect name Incoming sip

ip inspect name Incoming tcp router-traffic

ip inspect name Incoming udp router-traffic

ip inspect name Incoming icmp router-traffic

and bounded it to my interface by:

int dialer1

ip inspect Incoming out

Still no audio but i can initiate out and also receive calls but can't talk to anyone :-(

I am having a NAT issue hard to resolve (at least I am still trying to figuring out).

Thanks in advance


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Anonymous (not verified) Fri, 04/18/2008 - 11:33

The most likely problem with no way audio is the inability of the phone or gateway to route IP Packets to the other device. Check this out and if everything looks ok then please provide Detailed CCM traces of a problem call. If a gateway is involved please provide a show version and show run from the gateway.

andrew.butterworth Fri, 04/18/2008 - 12:05

I have SIP working with my 877, however I have outbound inspection of SIP enabled as well as inbound:

ip inspect name Outbound sip

ip inspect name Inbound sip


interface dialer1

ip inspect Inbound in

ip inspect Outbound out


Obviously there is more to the inspection rules however these are the relevent bits. Have you tried debugging? When I initially set this up I was debugging it and found the inbound traffic being denied as there was no knowledge of the SIP call without the outbound SIP inspection.



stephane.ricard Fri, 04/18/2008 - 12:22

I solve this issue and all seems to work fine so far. I've upgraded to Version 12.4(15)T4 and done the following commands:

ip nat piggyback-support sip all-messages router 1


ip nat sip-sbc


This Discussion