Agent Desktop not connecting to CTIOS Server

Unanswered Question
Apr 15th, 2008
User Badges:

Currently the Session object on my workstation will not connect to the CTIOS Server. I've checked the values for the CtiOsA, CtiOsB, PortA and PortB values and they are correct. They match what is currently working on another workstation.


CtiOsA = someIP_A

CtiOsB = someIP_B

PortA = 42028

PortB = 42028


I'm able to ping the IP addresses successfully, so I've got network connectivity to those servers. I was curious about what the Agent Desktop code might be getting as an error message so I had it dump the value of the pIArgument collection to a logfile on the OnConnectionFail event for the Session object. Here's the result of that dump.


Arguments contains 4 Args

EventTime:19058813

ReasonCode:3

FailedServer:localhost

ErrorMessage:CCtiOsSession: Cannot connect to a server.


I have no idea what to do with the Reason Code and cannot find any documentation on it. The interesting thing to me is that the failed server comes up as localhost instead of one of the CTIOS servers. I've looked through the CTI OS Troubleshooting guide but it hasn't helped me much for this issue. Does anyone happen to know what might be the issue here? Thanks for your time and attention.


Andrew

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

I have seen this problem before - today in fact. I have CAD installed and wanted to check something in CTIOS, so I installed that too and the 7.2(4) patch (to match the server). I configured the side A and side B hosts during setup, but the CTIOS Client would not start. The registry showed that my hosts were there - but the trace talked about localhost.


I ran Program Files\Cisco Systems\CTIOS Client\Setup.exe and the hosts were there as I expected. But after that, it worked.


Do not ask me why! ;-)


Regards,

Geoff

Chad Stachowicz Thu, 08/07/2008 - 16:15
User Badges:
  • Silver, 250 points or more

Guys,


I just uninstalled and reinstalled CAD, relicensed it. Now the clients are getting a cannot connect to CTIOS server? Any ideas?


Chad

Chad Stachowicz Sat, 08/09/2008 - 13:33
User Badges:
  • Silver, 250 points or more

I just uninstalled CTIOS, reinstalled it, upgraded it to 7.2(1) and worked no probs, not sure what happened...



Thanks as always!


Chad

Actions

This Discussion