campus manager 4.0 and vbjorb.jar

Unanswered Question
Apr 16th, 2008
User Badges:

I have serious issue couldn't access topology services on LMS 2.6. every time I opening the service the browser download Java pushed by CW server that is Java version 1.4.2_12 finished the download ask me restart the browser and I did. but this process not stop keep doing it. I cant access the service for a week.

at this time this is the only version on my PC. but i I have tried all Java version on all 1.4.2 serious.I am completely stop doing my job because of that. I have tried 3 other PC the same problem. any help greatly appreciated as always.

Eli

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Joe Clarke Wed, 04/16/2008 - 08:11
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Remove all versions of Java from the client, then download the JPI from the LMS server. Make sure to install it as a local Administrator on the client. When complete, you will have a lib\endorsed\vbjorb.jar file under wherever you have installed the Java Plug-in. If that file is zero bytes, then you did not install the plug-in as a local Administrator on the client.


Once the JPI and the vbjorb.jar file have been installed correctly, restarting all instances of your browser, then connecting back to Topology Services should work.

eliaspaulos Wed, 04/16/2008 - 08:22
User Badges:

thank you J, I got what you said 0 bytes. I 'm admin for this PC, I'm the one build it. the problem is not on my PC I have tried on my coworkers PC, who have Admin power. sometime it's download 100% but stay there with out nothing. but I am going try again and I will let you know guy's !!! thank you so much!!!

Joe Clarke Wed, 04/16/2008 - 08:27
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

If you install the plug-in from the CiscoWorks server, it will automatically install the vbjorb.jar file. You will not need to download it at the time you access Campus Manager. I suspect you have not installed the correct plug-in. As I said, remove all instances of Java from this client, then download the plug-in installer from the server. After its installation, you should see a non-zero byte vbjorb.jar file.


Note: it may be helpful to temporarily disable anti-virus software while doing this.

eliaspaulos Wed, 04/16/2008 - 09:28
User Badges:

J...some progress I have 1 byte size on VBjorb.jar instead of 0 but still the problem there. I don't have any Virus scan or firewall at this time waiting untill this thing is working.this thisngs really paused my job sadly....thank you again for your help.

Joe Clarke Wed, 04/16/2008 - 10:46
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The good file will be around 400 KB. Try manually downloading the JPI installer from the server. It can be found under NMSROOT/htdocs/plugin. Again, uninstall all other instances of the JPI from your client, then run the EXE with all browsers shutdown. At the end of the installation, you should see a DOS shell pop up. This indicates the vbjorb.jar file is being copied.

eliaspaulos Wed, 04/16/2008 - 12:00
User Badges:

J I just did as you told me, when I try to install the DOS window pop with blank but nothing is happen. don't you think the file on server itself is corrupted? is there any other place able to download this this vbjorb.exe. please let me know I hope this one will be my last question. thank you for your support.


Eli

Joe Clarke Wed, 04/16/2008 - 13:04
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You shouldn't see anything in the DOS window. The vbjorb.jar file is part of the JPI installer, so if the installer is launching, the jar file should not be corrupt.


However, you can find the file directly on the server. It is in NMSROOT/campus/www/classpath.

eliaspaulos Thu, 04/17/2008 - 06:07
User Badges:

thank you J. I found the soulution. finally I have tried an old pc it's downloaded from the server. then I copied the vbjorb.exe file and copied to all new pc's. because all showed 0 byte from this I got close to 2900kb. so I replace all the 0 file with this one. finally all pc work!!!!! why this old pc able to download..wellI don't know!! ....thank you so much for all your help.

Eli

Actions

This Discussion