location appliance down

Unanswered Question
Apr 16th, 2008
User Badges:

WCS is reporting that it cannot communicate with my location appliance. I can ping the appliance, I rebooted while connected via the console and did not notice any errors upon bootup. Is there anything that can be done via WCS to initiate this connection? Is there anything on the location device itself? Wanted to check here before placing call to TAC.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Scott Fella Tue, 04/22/2008 - 16:54
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Delete the snmp and recreate it on both the wcs and the loc app. See if that works.

Matthew Fowler Tue, 04/22/2008 - 17:03
User Badges:
  • Cisco Employee,

While the WLA may be pingable, the locserv process may not be running.


You can always check this by using the 'getserverinfo' command. If you get Java output then the process isn't running or has problems.


You can check with ps -ax | grep locserv. If you see nothing, it isn't started. You can restart the process with /etc/init.d/locserverd start.


If this doesn't work, there may be some errors in the database. In this case, we may need to delete the database. Before doing this, you may want to grab the logs (/opt/locserver/logs) and open a TAC case.



ps -ax | grep locserv (kill anything that remains- "kill -9 ")


cd /opt/locserver/db/linux


rm -f server-eng.db

-go to cd /opt/locserver/installers


-Uninstall the current version

-Install again


/etc/init.d/locserverd start


/opt/locserver/bin/getserverinfo

derawat28 Fri, 11/27/2009 - 21:18
User Badges:

Hi Guys,


I am also having similar issue but my LOC appliance is not down all the time infact for a short while my WCS sends me e-mail alerts stating that my LOC (IP address) port 8001 is down and after a while come back again and again repeating same alarms after few hours interval.


I wonder if any expert could help me here to dig out this issue....



A bunch of thanks in advance.


Thanks and Regards

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode