Rommon

Unanswered Question
Apr 16th, 2008

i have a Sup V 10GE that got into rommon when it was upgraded to a different IOS.

It failed to boot to the new IOS and stops at the error below and reboots again.

Rommon reg: 0x0E000380

#################################

UNHANDLED ROMMON EXCEPTION at PC=0b000c00

Vector=00000100 MSR=02021200 LR=0b000794

MCSR=00000000

CISR0=00000000 CISR1=20000000

DDR_ERR_DETECT=00000008

What could the error mean? This couldnt be hardware right since it was working before it was upgraded.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
vaisharm Wed, 04/16/2008 - 22:50

Hi Brenda,

If you see ROMMON>, capture the following outputs:

ROMMON1>dev

This would list all flash file systems on the Sup.

Next, try to view the contents of the valid installed flash memory option, ie.,

(choose the appropriate option(s))

dir flash:

dir bootflash:

dir slot0:

dir slot1:

If you see a valid IOS in any of these locations, use the following command:

boot :filename

For example, if there is a valid IOS file in in slot0, you would use the following command:

boot slot0:IOS_file.bin

Please post these outputs.

HTH,

~Vaibhav

brenda.ombao Wed, 04/16/2008 - 23:20

Hi vaibhav,

I think you are in my yahoo messenger list..

Anyways, my sup engine uses bootflash. I have tried already that command but to no avail. The error that i have posted in my first post still appears and continues to cycle.

I am thinking of copying another IOS into the flash. Can i use tftp on rom monitor? I tried xmodem but it didnt work. I tried assigning an ip address to the management interface but i cant ping it! sigh ill do all these again on monday. I need all your suggestions thank you

brenda.ombao Thu, 04/17/2008 - 01:27

I hope this works the second time. If not, can i assume that this is a hardware issue already?

vaisharm Thu, 04/17/2008 - 01:42

Before you try anything else I would suggest removing all the line cards, reseating the SUP and the DRAM. Then try booting with just the SUP and no line cards. Try to recover the SUP without any linecards in the chassis.

If it still doesn't work (after you have followed the steps for recovery from rommon as mentioned in the documents in the previous post), its HW failure.

HTH

~Vaibhav

Actions

This Discussion