Why cdp shown these Vlan3 IP address

Answered Question
Apr 17th, 2008

My question is:

Why am I seeing the IP address of 10.98.3.3 while issue “sh cdp neighbor detail” on 6513-01? and

why it is using IP address of vlan3 since I have number of the other vlan with IP address configured?

What could be the possible configuration that cause the output as shown by the “sh cdp neighbor detail” below?

Hope that I am providing enough information, below are the setup.

- 2x 6513 switch trunk together through g1/1 and g2/1.

- It is running in the OSPF environment.

- Both switches are configure with loopback 0 with IP address as 172.16.1.1 and 172.16.1.2 respectively.

- IP address are not configure on both the g1/1 and g2/1 at both the 6513 switch.

- Both the 6513 switches are configure with number of vlans

- the interface g1/1, g2/1 and port-channel 2 are not configure with IP address.

- Noted that the IP address 10.98.3.3 are confiure in 6513-02 it belong to the IP address of interface vlan3.

The 6513 configuration are as follow:

-------------------------------------------------------------------

Both configuration for GigabitEthernet1/1 and GigabitEthernet2/1 are similar:

interface Port-channel2

switchport trunk encapsulation dot1q ; switchport mode trunk; no ip address

interface GigabitEthernet1/1 (and also GigabitEthernet2/1)

switchport; switchport trunk encapsulation dot1q; switchport mode trunk; no ip address

channel-group 2 mode desirable

------------------------------------------------------------

sh cdp neighbor detail

Device ID: DS6513-02.abc.com

Entry address(es):

IP address: 10.98.3.3

Platform: cisco WS-C6513, Capabilities: Router Switch IGMP

Interface: GigabitEthernet2/1, Port ID (outgoing port): GigabitEthernet2/1

-------------------------

Device ID: DS6513-02.abc.com

Entry address(es):

IP address: 10.98.3.3

Platform: cisco WS-C6513, Capabilities: Router Switch IGMP

Interface: GigabitEthernet1/1, Port ID (outgoing port): GigabitEthernet1/1

----------------------------------------------------------------------

interface Vlan3;

ip address 10.98.3.3 255.255.255.0

standby ip 10.98.3.1; standby preempt

router ospf 1

log-adjacency-changes; area 9 stub; summary-address 10.98.0.0 255.255.224.0

passive-interface Vlan3; passive-interface Vlan5

passive-interface Loopback0

network 10.98.0.0 0.0.31.255 area 9

network 10.98.255.0 0.0.0.7 area 9

network 10.98.255.128 0.0.0.7 area 9

thanks in advance

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 8 years 7 months ago

Once an adjacency is formed then yes packets can be routed between the 2 switches over the port-channel.

" Assuming that Vlan 4 and vlan 5 are not configure as passive interface, it is true that “sh ip route ospf” will have the follow output?"

Yes.

Jon

Correct Answer by Edison Ortiz about 8 years 7 months ago

CDP will use the lowest number Vlan's Layer3 information to populate the "IP Address" field on the "show cdp neighbor detail" output.

In your case, Vlan3 is the first 'numbered Vlan on switch "DS6513-02.abc.com".

HTH,

__

Edison.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
nikhil.engineer Thu, 04/17/2008 - 03:41

hi,

If i am not wrong this is what I understand from your configuration:-

6513--g1/1---trunk----g2/1--6513

is this correct ?

Please do let me know.

Cheers,

Nikhil E.

ezsurf0902 Thu, 04/17/2008 - 07:42

Hi,

My 6513 setup is:

6513 --g1/1 --trunk --g1/1 6513

........ --g2/1 -- "" --g2/1

thank, hope you can help.

Correct Answer
Edison Ortiz Thu, 04/17/2008 - 06:19

CDP will use the lowest number Vlan's Layer3 information to populate the "IP Address" field on the "show cdp neighbor detail" output.

In your case, Vlan3 is the first 'numbered Vlan on switch "DS6513-02.abc.com".

HTH,

__

Edison.

ezsurf0902 Thu, 04/17/2008 - 08:05

Hi ediortiz,

I am unable to get the infor, could you kindly provide the link for that info.

thanks

Edison Ortiz Thu, 04/17/2008 - 10:16

It's not documented, I found such behavior by actually trying in a switch.

__

Edison.

ezsurf0902 Fri, 04/18/2008 - 00:12

Edison,

Thanks for your sharing, so, in layer 2 the sh cdp command will show the lower vlan's IP address. This lead to another issue on layer 3, ospf.

At the same 6513-1 and 6513-2

no IP address are configure for both the g1/1 and g2/1 that “running port-channel 2”

Under the config:“router ospf” all the vlan are configure as passive interfaces except vlan 4

with the follow output

DS6513-01#sh ip route ospf

O 10.98.255.132/30 [110/2] via 10.98.255.129, 7w0d, GigabitEthernet2/2

[110/2] via 10.98.4.3, 7w0d, Vlan4

O 10.98.1.2/32 [110/2] via 10.98.4.3, 7w0d, Vlan4

My question is why the packet is route through Vlan4? which from my document Vlan4 is the “port-channel 2” which there is no IP address configure on it.

Will it be the same theory like cdp it take the lower vlan? And for this case layer 3 ospf take the lower vlan which in this case not configure as passive interfaces?

Thank in advance.

Jon Marshall Fri, 04/18/2008 - 00:18

The adjacency is formed because vlan 4 is not passive under your OSPF configuration. Are you saying that vlan 4 has no ip address on either switch ? ie. if you do

sh run int vlan 4

is there an IP address there.

OSPF does not function in the same way as CDP ie. it uses all vlans that are not passive so if none of the vlans were made passive under the router ospf config then you would see an entry in the routing table using each vlan interface.

Does this make sense ?

Jon

ezsurf0902 Fri, 04/18/2008 - 00:54

Sorry, what i mean is that port-channel 2 has no IP address not vlan 4.

- Do you mean the routing is form because of adjacency is form?

- Assuming that Vlan 4 and vlan 5 are not configure as passive interface, it is true that “sh ip route ospf” will have the follow output?

DS6513-01#sh ip route ospf

O 10.98.255.132/30 [110/2] via 10.98.255.129, 7w0d, GigabitEthernet2/2

[110/2] via 10.98.4.3, 7w0d, Vlan4

[110/2] via 10.98.4.3, 7w0d, Vlan5

thanks

Correct Answer
Jon Marshall Fri, 04/18/2008 - 00:57

Once an adjacency is formed then yes packets can be routed between the 2 switches over the port-channel.

" Assuming that Vlan 4 and vlan 5 are not configure as passive interface, it is true that “sh ip route ospf” will have the follow output?"

Yes.

Jon

Actions

This Discussion