MGCP FXS Port

Unanswered Question
Apr 17th, 2008

Hi Guys,

Does anyone have experience troubleshooting FXS ports ? I have a 2port VWIC and a 4 port VWIC. The two port is working fine but the 4 port has no dial tone on any of the ports.Done a sh voice port summ and i can see the port ring on incoming calls and therefore go off/on hook again.

Any help appreciated thanks...

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Kenneth Mohammed Thu, 04/17/2008 - 07:59

Have you taken your analog phone, bypassed all internal wiring (patch panels, etc) and plugged it directly into the fxs card, and then see if you can get dial tone. If you do, then it could be an issue with internal wiring. Also, I am assuming that the ports are registered w/the CCM??

Steellllllllll0 Thu, 04/17/2008 - 08:01

There is no panels between the VWIC and the fax machine.There is just a straight cable.

Kenneth Mohammed Thu, 04/17/2008 - 08:26

Do you have a known working 4 port fxs card that you can try swapping with just to eliminate a bad card. However, I dont think the card is bad due to the fact that you can see the port ring-det and go on/off hook, but its worth a try if you have a spare card available to you.

pauruizperez Sat, 04/19/2008 - 14:29

Maybe silly response but ...,

Have you checked you have enough DSPs to support the ¿VIC2?-4FXS.

If it's a 17xx this would require a minimum PVDM-256K-8 (2 DSP)

If it's an ISR router this would require a minimum PVDM2-8

If you want to support at the same time the two cards (VIC-2FXS and VIC-2FXO) then you'll need at least three DSPs (PVDM-256K-12 or PVDM2-16)

I think it's a full or nothing if there's not enough DSPs (no way of enabling only the two lower ports on the VIC2-4FXS if you only have 1 DSP)

I think the router will show something on boot if that's the case. Try with a cable console on boot, or just "show log".

You have to see all FXS FXO cards connected to the router when you do a "show version" in the form of "N Voice FX* interfaces"

Hope this helps, please report "show inventory", or as much info about your configuration (software/hardware) as you could provide...

Steellllllllll0 Mon, 04/21/2008 - 02:28

hi Guys,

show ver :

Cisco 3845 (revision 1.0) with 222208K/39936K bytes of memory.

Processor board ID FTX1031A3QF

2 Gigabit Ethernet interfaces

25 Serial interfaces

1 terminal line

2 Channelized T1/PRI ports

2 Virtual Private Network (VPN) Modules

2 Voice FXO interfaces

6 Voice FXS interfaces

1 cisco service engine(s)

show inventory ;

NAME: "Four port FXS DID voice interface daughtercard", DESCR: "Four port FXS DID voice interface daughtercard"

PID: VIC-4FXS/DID= , VID: 3.1, SN:

NAME: "PVDMII DSP SIMM with four DSPs", DESCR: "PVDMII DSP SIMM with four DSPs"

PID: PVDM2-64 , VID: V01 , SN:

NAME: "PVDMII DSP SIMM with three DSPs", DESCR: "PVDMII DSP SIMM with three DSPs"

PID: PVDM2-48 , VID: V01 , SN:

All of the above seems to be fine.When doing a debug isdn q931 i can see the incoming call.When doing a debug on the dial peers i dont get no output.Gateway is mgcp so not sure if thats the reason.I am now unable to see the ports go off/on hook and just getting a straight busy tone on incoming calls.I have also tried a reload but has not made any difference.

Any help appreciated !!

dinorubio Mon, 04/21/2008 - 09:12

mgcp fxs "don't" use router dial-peers, they use CM route patterns. you must create a MGCP gateway on CManager.

Steellllllllll0 Tue, 04/22/2008 - 02:12

Hi,

I have really run out of ideas now to solve this so any help would be appreciated.As things stand all incoming calls on for the FXS ports are permanently busy although i can see them coming in if i debug the q931.At first they rang and i could see the ports go off/on hook but now nothing is happening.I have tried rebooting the router several times but this isnt changing anything.I do have mgcp configured and tried stop/restarting it several times also still nothing.

Pls help...

dinorubio Tue, 04/22/2008 - 02:54

are you using one-pair cable? just 1pair on the middle? i think it's a cabling problem... by the way have you checked the bug toolkit to see if cisco identified a bug on that ios version?

regards,

Steellllllllll0 Tue, 04/22/2008 - 04:15

I dont think its particularly a cabling problem as since i rebooted the router this morning they now have dial tone and they can send faxes.Problem is with incoming calls they just permanently busy.I tried testing the port also and it rings the endpoints.....

pauruizperez Tue, 04/22/2008 - 04:20

I had the same issue after enabling stcapp (SCCP for a FXS port) on a 1700.

Doing a no stcapp on the dial-peer voice xxx pots made the port work again.

It's strange because IOS 12.4.T.15 doesn't have support for SCCP in FXS ports, but let you configure as it would work...

If the configuration is the same exactly as the VIC2-2FXS, please omit this response.

Steellllllllll0 Tue, 04/22/2008 - 04:47

Hi,

Thanks for your reply.I am using a 3845 and dont have that as part of my configuration neither do i have it as an option on my IOS...

Steellllllllll0 Wed, 04/23/2008 - 06:18

Hi guys,

This was finally resolved by deleting the lines one by one totally from CCM and rebuilding them on the gateway.

Actions

This Discussion