3550 not showing auto speed

Unanswered Question
Apr 17th, 2008

Im working with my server team and they are requesting i change the port setting on the 3350 to auto speed. I understand that gig ports can only be set to full. But I am used to seeing "auto" in the show interface command...but i am not seeing it here. Nor is the configuration showing auto. Is this becuase it is the default?

igabitEthernet2/0/21 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0019.5639.0c95 (bia 0019.5639.0c95)

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

3550#conf t

Enter configuration commands, one per line. End with CNTL/Z.


3550-sw(config)#interface GigabitEthernet2/0/21


3550(config-if)#duplex auto

Gigabit port is restricted to full duplex

3550(config-if)#speed auto


3550#sh run int GigabitEthernet2/0/21

Current configuration : 170 bytes


interface GigabitEthernet2/0/21

switchport access vlan 212

switchport mode access


duplex full

spanning-tree portfast

spanning-tree bpduguard enable


3550#sh interfaces gigabitEthernet 2/0/21 status

Port Name Status Vlan Duplex Speed Type

Gi2/0/21 connected 212 full a-1000 10/100/1000Ba


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
s.marino Thu, 04/17/2008 - 09:08

when you type in the command: (show interface status) you will see the Duplex and Speed setting for each port.

Hope this helps.

s.marino Thu, 04/17/2008 - 09:22

Sorry I forgot to add that this is a default and what you have displayed is correct.

"Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX" the (show interface status) command will display the Duplex a-full and Speed a-1000.

Hope this helps. Please rate it if it does.



This Discussion