Can't configure an IP in the range on a Catalyst Express 500g

Unanswered Question
Apr 17th, 2008


I have 4 catalyst Express 500G-12TC switches that I am configuring for the first time. I am able to access the initial web setup screen, but when I enter the static IP address (172.16.9.x) that I want to assign to the switch I receive the following error:

"The IP address in the network cannot be configured on this switch."

I have the following information entered:


Subnet Mask


I tried looking in the troubleshooting guide for this switch, but was unable to find anything specific to this error. Does anyone know why I'm unable to configure this IP?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Rick Arps Wed, 05/21/2008 - 13:39


There's no reason you shouldn't be able to use private addresses for internal vlan interfaces... That's what they're for!

Have you tried setting this from the command line?

Configure terminal

int vlan1

ip address

ip default-gateway


copy running-config startup-config



ohassairi Thu, 05/22/2008 - 00:23

hi rick

as i know these switches have no console port!

if some one can ask cisco team why they did it like this ?

sirdudesly Wed, 05/21/2008 - 22:23

Does it block you from making the change to prevent you losing access to the webgui perhaps?

lguskey99 Thu, 05/22/2008 - 08:14

Thanks to everyone for posting their thoughts on this issue. After a call to Cisco Tech Support, it was determined that 1 switch was defective, and the remaining 3 required IOS upgrades. Cisco sent out a new switch, we imaged the other 3 and everything worked fine.

Thanks again for all your help.



This Discussion