dsl, lan - wan - connection

Unanswered Question
Apr 17th, 2008
User Badges:

hi there,

i got a 1841 router and i have a dsl - line. i get a public ip, but i do not have access to the internet. i have no idea why... can anyone help me? thanks a lot.


actual config:


Current configuration : 1964 bytes

!

! Last configuration change at 19:27:35 METDST Thu Apr 17 2008

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname pfistyle

!

boot-start-marker

boot-end-marker

enable secret 5 xxxxxxxxxxxxxxxxxxxxxx

!

!

clock timezone MET 1

clock summer-time METDST recurring last Sun Mar 2:00 last Sun Oct 2:00

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

ip name-server 193.x.227.3

ip name-server 195.x.56.5

ip name-server 194.x.230.53

vpdn enable

!

vpdn-group pppoe

request-dialin

protocol pppoe

!

no ftp-server write-enable

!

no virtual-template subinterface

!

!

!

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface ATM0/0/0

mac-address 0013.199e.2e29

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

hold-queue 224 in

pvc 8/35

encapsulation aal5snap

pppoe-client dial-pool-number 1

!

!

interface Virtual-Template1

no ip address

!

interface Dialer1

ip address negotiated

ip directed-broadcast

ip nat outside

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp chap hostname [email protected]

ppp chap password 7 xxxxxxxxxxxxxxxxx

ppp pap sent-username [email protected] password 7 xxxxxxxxxxxxxxxx

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

no ip http server

!

dialer-list 1 protocol ip permit

!

control-plane

!

!

line con 0

password 7 xxxxxxxxxxxxxxxxxxxxx

login

line aux 0

line vty 0 4

password 7 xxxxxxxxxxxxxxxxxxxx

login

line vty 5 15

password 7 xxxxxxxxxxxxxxxxxxxx

login

!

ntp clock-period 17178794

ntp server 134.93.132.118

ntp server 129.132.2.21 prefer

end






  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Kenneth Mohammed Thu, 04/17/2008 - 10:09
User Badges:
  • Silver, 250 points or more

I see you have nat specified on your lan and dialer interfaces, but there are no nat translation statements in your config..I think you need to configure nat to translate your inside addresses to a public routable IP.


Try adding this and see if it works:


ip access-list extended nating

permit ip 192.168.1.0 0.0.0.255 any

permit ip any any


route-map NAT permit 5

match ip address nating


ip nat inside source route-map NAT interface Dialer1 overload


and of course also make sure your pc is using the correct ip and subnet mask, as well as default gateway, as I see that you also dont have the router providing dhcp services.



hope that helps...

Actions

This Discussion