Unified Personal Communicator issue

Answered Question
Apr 17th, 2008
User Badges:

Hello,

I am running CUCM 6.1, CUPs 6. My CUPC clients are having problems. They authenticate ok, can talk to a desk phone OK, havent setup MP or Unified Comm yet. However, under the "server health" it cannot connect to presence. The error is "failed to connect" no servers configured. The troubleshooting on CUPs shows no issues. I have the Presence server specified on CUCM.

Thanks!

Adam

Correct Answer by Tommer Catlin about 9 years 1 week ago

In the description type in All

in the address pattern type in all (small caps)


Do this for outgoing as well.

Correct Answer by Tommer Catlin about 9 years 1 week ago

Something in the SIP trunk. Restart your SIP proxy service. Also check to make sure you have add in the incoming and outgoing ACLs to "all" so it accepts and sends out the SIP messages By default this is turned to deny. It's wonderful Cisco documentation that stinks.


Check your "troubleshooter" on the CUPS server to make sure everything is ok.


CTI is working, because you can control the phone

Also check the following:

All Presence users have digested credentials. (anything filled in works, they will never use it)

Line associated to CUCM end users. If this in not selected, then presence will not show of the person.


Try changing all your SIP trunk settings to IP address only.

If have a subscriber server in Presence, shut it down and test with one server first.


Hope this helps

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
Tommer Catlin Thu, 04/17/2008 - 10:03
User Badges:
  • Green, 3000 points or more

Something in the SIP trunk. Restart your SIP proxy service. Also check to make sure you have add in the incoming and outgoing ACLs to "all" so it accepts and sends out the SIP messages By default this is turned to deny. It's wonderful Cisco documentation that stinks.


Check your "troubleshooter" on the CUPS server to make sure everything is ok.


CTI is working, because you can control the phone

Also check the following:

All Presence users have digested credentials. (anything filled in works, they will never use it)

Line associated to CUCM end users. If this in not selected, then presence will not show of the person.


Try changing all your SIP trunk settings to IP address only.

If have a subscriber server in Presence, shut it down and test with one server first.


Hope this helps

ahab Thu, 04/17/2008 - 10:10
User Badges:

I appreciate the quick response! I am going through it now.

Can you post a sample of the "all" for the ACLs? I think I may have issues there.


I'll update once I have gone through the other items.


Many thanks!

Correct Answer
Tommer Catlin Thu, 04/17/2008 - 10:13
User Badges:
  • Green, 3000 points or more

In the description type in All

in the address pattern type in all (small caps)


Do this for outgoing as well.

ahab Thu, 04/17/2008 - 10:33
User Badges:

Changing the ACLs did the trick!


Now I cant pull phone number info for other users to place a call to them from the app. Is this in my LDAP settings I assume? I am pointing CUPs to my Global Catalog server for LDAP.

Tommer Catlin Thu, 04/17/2008 - 10:36
User Badges:
  • Green, 3000 points or more

Yes. If you want use the LDAP to add other CUPC to the "buddy list". If they are not in the list, then you cant IM them, etc. You will need to pick a field in LDAP for the extension number. I use ipPhone and enter the extension of the subscriber in this.


Good to point to the GC... seems to be the only way that it works for whatever reason.



Actions

This Discussion