Etherchannel will not come up on Catalyst 6509

Answered Question
Apr 17th, 2008
User Badges:


I am connecting to core switches together via etherchannel on their 10G ports

I AM Running s72033-ipservices_wan-vz.122-18.SXF9.bin on THE 2 6509s for some reason the 10G ports on core b will not come up. Config listed below. I do a no shut and it still says shut down



Core A

*****************************

interface TenGigabitEthernet9/1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

no ip address

channel-group 1 mode on

!

interface TenGigabitEthernet9/2

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

no ip address

channel-group 1 mode on





interface Port-channel1

description Etherchannel link to Core B

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

no ip address


Core b

**********************

interface TenGigabitEthernet9/1

description Etherchannel link to Core A

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

shutdown

no ip address

channel-group 1 mode on

!

interface TenGigabitEthernet9/2

description Etherchannel link to Core A

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

shutdown

no ip address

channel-group 1 mode on


interface Port-channel1

description Etherchannel Port to Core A

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

no ip address


Correct Answer by Istvan_Rabai about 9 years 1 week ago

Hi Keith,


Do the trunks come up as standalone trunks without configuring etherchannel?


Please try to do this first of part of the troublesghooting process.


This way we can isolate if this is an Etherchannel problem or it is something different.


Please inform us about your experience.


Thanks:

Istvan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Jon Marshall Thu, 04/17/2008 - 14:45
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Your physical ports on Core b - they are in a "shutdown" state. Is this a typo ?


Jon

keith.k.quaye Thu, 04/17/2008 - 14:50
User Badges:

No Jon that is the crux of my problem when I go into the inteface and do a no shut it stays shut and thats what the current running config looks like I am scractching my head trying to figure out why.



lamav Thu, 04/17/2008 - 17:20
User Badges:
  • Blue, 1500 points or more

Hi:


For EtherChannel to come up, make sure:


All ports are configured with the same speed and duplex settings.


All ports are in the same vlan.


The same vlans are being allowed on each of the trunk ports you would like to make part of the channel.


Both switches are in the same VTP domain.


Check those things first.


HTH


Victor



Correct Answer
Istvan_Rabai Thu, 04/17/2008 - 21:20
User Badges:
  • Gold, 750 points or more

Hi Keith,


Do the trunks come up as standalone trunks without configuring etherchannel?


Please try to do this first of part of the troublesghooting process.


This way we can isolate if this is an Etherchannel problem or it is something different.


Please inform us about your experience.


Thanks:

Istvan

keith.k.quaye Fri, 04/18/2008 - 12:26
User Badges:

Istvan,

I did what you suggested and even went further I reseated the card then I took the etherchannel config off the card. It came up as a stand alone trunk. So then I redid the etherchannel config and it came up.

lamav Fri, 04/18/2008 - 12:30
User Badges:
  • Blue, 1500 points or more

Keith:


So are you saying its up now?


If I had ot take an educated guess, I dont think reseating the cards fixed anything. I would say it was bouncing the etherchannel config.


VL

keith.k.quaye Fri, 04/18/2008 - 12:36
User Badges:

VL

Yes it is up and I agree with you that was just as a sanity check since I couldn't get the physical interface to unshut it kept saying it was shut down and I wanted to make sure it was recognizing the xenpak.


Keith

Actions

This Discussion