Routing Lab Question, cant ping vlan ip

Answered Question
Apr 18th, 2008

This is driving me nuts. I'm sure the problem is starring me in the face but i need a little help.

I am working on a BSCI lab for multicasting but I have a routing problem.

Here is the setup.

R1 < - > R2 < - > SW1

R1 s1/0 connects to R2 s1/0 via serial.

R2 fa0/0 connects to a switch SW1 f1/1 via fastethernet.

SW1 has VLAN20 in its vlan database.

SW1 fa1/1 has switchport mode access, and switchport access vlan20 applied.

*SW1 has "ip default-gateway 172.16.20.2" applied

the serial link has IP of 172.16.102.0/29 with R1 on .1 and R2 on .2

The fastethernet link has an IP of 172.16.20.0/24 with R2 fa0/0 on .2

VLAN20 on SW1 has the ip of 172.16.20.4

EIGRP is setup on R1 and R2 with the following setup:

Router EIGRP 1

Network 172.16.0.0

R1 can not ping 172.16.20.4

R1 has a route to 172.16.20.0/24 via R2's serial link.

my brain(and the lab i am working on) says this should work but it doesnt.

any thoughts?

any help is greatly appreciated.

Eric

*crap, sorry had some incomplete information

I have this problem too.
0 votes
Correct Answer by sundar.palaniappan about 8 years 9 months ago

Jon

I am thinking ip routing may be enabled in the switch, which would make ip default-gateway command irrelevant.

Eric

Can you post 'show ip route' from the switch.

HTH

Sundar

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Jon Marshall Fri, 04/18/2008 - 07:05

Eric

Is the switch a layer 2 or layer 3 switch. If layer 2 have you set the "ip default-gateway" to point 172.16.20.2.

Also can you confirm the vlan interface 20 is actually up ie.

sh ip int br

Jon

Eric Hansen Fri, 04/18/2008 - 07:07

sorry, i forgot to include that bit. I just edited it as you posted your reply. Sorry about that.

And yes, VLAN20 shows up and up. and so does fa1/1

Eric Hansen Fri, 04/18/2008 - 07:08

sorry, i forgot to include that bit. I just edited it as you posted your reply. Sorry about that.

And yes, VLAN20 shows up and up. and so does fa1/1

switch is a 3660 with a NM-16esw blade. layer 2

Jon Marshall Fri, 04/18/2008 - 07:13

Can you

1) ping 172.16.20.4 from 172.16.20.2

2) ping 172.16.20.2 from 172.16.102.1

3) ping 172.16.102.1 from 172.16.20.2

Can you post "sh ip ro" from R1 and R2.

Jon

Eric Hansen Fri, 04/18/2008 - 07:34

using extended pings...

1) ping 172.16.20.4 from 172.16.20.2

YES

2) ping 172.16.20.2 from 172.16.102.1

YES

3) ping 172.16.102.1 from 172.16.20.2

YES

Can you post "sh ip ro" from R1 and R2.

Sure, i took the code legend out.

R1#show ip route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks

D 172.16.20.0/24 [90/20514560] via 172.16.102.2, 00:07:35, Serial1/0

C 172.16.102.0/29 is directly connected, Serial1/0

R2#show ip route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 172.16.20.0/24 is directly connected, FastEthernet0/0

C 172.16.102.0/29 is directly connected, Serial1/0

thanks Jon, i didnt expect the 3rd ping to work.

e-

Eric Hansen Fri, 04/18/2008 - 10:00

Could it be maybe an issue with discontiguous subnets? Since the serial link is 172.16.102.0 and the fastether is 172.16.20.0...

dont know, i am grabbing at straws.

e-

Jon Marshall Fri, 04/18/2008 - 10:08

Eric

No i don't think it's discontiguos subnets. Coudl you post the full configs for all devices. I suspect it is an issue with the switch.

Jon

Eric Hansen Fri, 04/18/2008 - 10:32

Sure thing, here you go.

R1

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

no aaa new-model

ip subnet-zero

!

no ip domain lookup

!

ip cef

ip audit po max-events 100

!

interface Serial1/0

bandwidth 128

ip address 172.16.102.1 255.255.255.248

serial restart-delay 0

clock rate 128000

!

router eigrp 1

network 172.16.0.0

auto-summary

!

ip classless

no ip http server

no ip http secure-server

!

gatekeeper

shutdown

!

!

line con 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

!

!

end

R2

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

no aaa new-model

ip subnet-zero

!

no ip domain lookup

!

ip cef

ip audit po max-events 100

!

interface FastEthernet0/0

ip address 172.16.20.2 255.255.255.0

duplex full

!

interface Serial1/0

bandwidth 128

ip address 172.16.102.2 255.255.255.248

serial restart-delay 0

!

router eigrp 1

network 172.16.0.0

auto-summary

!

ip classless

no ip http server

no ip http secure-server

!

gatekeeper

shutdown

!

!

line con 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

!

!

end

SW1#

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SW1

!

boot-start-marker

boot-end-marker

!

no aaa new-model

memory-size iomem 5

!

ip cef

no ip domain lookup

!

interface FastEthernet1/1

switchport access vlan 20

!

interface Vlan1

no ip address

!

interface Vlan20

ip address 172.16.20.4 255.255.255.0

!

ip default-gateway 172.16.20.2

ip http server

ip forward-protocol nd

!

control-plane

!

line con 0

line aux 0

line vty 0 4

login

!

!

end

SW1#vlan database

SW1(vlan)#show

VLAN ISL Id: 1

Name: default

Media Type: Ethernet

VLAN 802.10 Id: 100001

State: Operational

MTU: 1500

Translational Bridged VLAN: 1002

Translational Bridged VLAN: 1003

VLAN ISL Id: 20

Name: VLAN0020

Media Type: Ethernet

VLAN 802.10 Id: 100020

State: Operational

MTU: 1500

Jon Marshall Fri, 04/18/2008 - 10:47

Eric

I have just labbed this up with 2 routers (2621XM's) and a switch (3560) and it works fine ie. i have full connectivity.

Can you post "sh cdp neigh" from the switch.

Not sure what is wrong here as configs look good.

Jon

Correct Answer
sundar.palaniappan Fri, 04/18/2008 - 10:55

Jon

I am thinking ip routing may be enabled in the switch, which would make ip default-gateway command irrelevant.

Eric

Can you post 'show ip route' from the switch.

HTH

Sundar

Jon Marshall Fri, 04/18/2008 - 10:59

Sundar

I think you may well be right. I didn't think the NM-16esw module in a 3660 could do L3 routing.

If it fixes it i'll rate :-)

Edit - just looked it up and it can.

Jon

Eric Hansen Fri, 04/18/2008 - 11:02

DOH!

SW1#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 1 subnets

C 172.16.20.0 is directly connected, Vlan20

SW1#

so... issue a "no ip routing" on SW1?

e-

Eric Hansen Fri, 04/18/2008 - 11:08

you guys rock, thanks so much for the help today.

who wants the rating?

SW1#ping 172.16.102.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.102.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/320/1068 ms

SW1#

R1#ping 172.16.20.4

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.20.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/204/504 ms

R1#

:) <--- this is me, really happy.

e-

sundar.palaniappan Fri, 04/18/2008 - 11:11

Eric

Glad to hear it's working :-)

Honestly, you should rate both as Jon did a big chunk of the work and I only gave the finishing touches.

HTH

Sundar

Jon Marshall Fri, 04/18/2008 - 12:05

Looks like you've got it now :-) Like to add my congratulations to Mohammed's.

Jon

Actions

This Discussion