OSPF F/R 'ip ospf network broadcast'

Unanswered Question
Apr 18th, 2008
User Badges:

Hi,

I have a hub & spoke design in my Lab.

2 spokes, 1 hub in a partial mesh config. I am using 'ip ospf net broadcast' on the serial sub-interfaces of each router. I have full connectivity.

I have frame-relay 'map' statements on each spoke pointing to the other spoke. I am not using the broadcast keyword on the map statements but still have full connectivity ???

Doyle I, is suggesting that I need this 'broadcast' keyword to forward multicast/broadcasts on this network type.

Although Doyle is using physical interfaces not sub-interfaces.


What am I missing here ?


Regards,


Phil.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Richard Burts Fri, 04/18/2008 - 07:57
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Phil


You mention having serial subinterfaces. Are these point to point serial subinterfaces? If so what you are missing is that ptp subinterfaces support broadcast/multicast by definition. You do not need the broadcast statement on the map because the broadcast/multicast is natively supported. In fact you usually do not have map statements with ptp serial subinterfaces, so the broadcast keyword is usually not an issue with ptp serial subinterfaces.


HTH


Rick

philth_123_2 Fri, 04/18/2008 - 08:17
User Badges:

Rick,

I'm using multi-point sub-interfaces. I'm just gonna try a reboot incase something has been corrupted by previous configs.


Phil.

philth_123_2 Fri, 04/18/2008 - 08:40
User Badges:

Reboot is the same ...


spoke 2


Interface Serial 0

no ip address

encapsulation frame-relay

no fair-queue

frame-relay lmi-type cisco

!

Interface Serial 0.100 multipoint

ip address 192.168.10.2 255.255.255.248

ip ospf network broadcast

ip ospf priority 0

frame-relay map ip 192.168.10.3 100

frame-relay interface-dlci 100

!

router ospf 1

network 192.168.10.0 0.0.0.7 area 0

!


hub


Interface Serial 0.101 multipoint

ip address 192.168.10.1 255.255.255.248

ip ospf network broadcast

frame-relay interface-dlci 101

frame-relay interface-dlci 201

!

Hmmmmm ? 'frame-relay interface-dlci ...'


Not sure how this could be affecting things


Phil

mohammedmahmoud Fri, 04/18/2008 - 10:03
User Badges:
  • Green, 3000 points or more

Hi Phil,


It is "frame-relay interface-dlci", please check the output of "show frame map", and please check the following:


!

interface Serial0/0/0.2 multipoint

ip address 100.6.1.6 255.255.255.0

frame-relay interface-dlci 101


Rack6R6#sh fram map

Serial0/0/0.2 (up): ip 100.6.1.254 dlci 101(0x65,0x1850), dynamic,

broadcast,

IETF, status defined, active


[edit] To explain what i wanted to say with the above output, if the command "frame-relay interface-dlci" is used under a multipoint subinterface, then the DLCI will be learned dynamically and supporting broadcast by default.



BR,

Mohammed Mahmoud.

lamav Fri, 04/18/2008 - 10:16
User Badges:
  • Blue, 1500 points or more

Phil:


You don't need the broadcast keyword in the static mapping command because you have also configured the multipoint subinterfaces to use inverse ARP (dynamic mapping) to do the protocol address/DLCI mapping.


When frame-relay inverse-arp is enabled, broadcast IP traffic will go out over the connection by default.


If you remove the frame-relay interface-dlci command from the subinterfaces, you will then have to use the broadcast keyword for the static mapping.


HTH


Victor



lamav Fri, 04/18/2008 - 10:18
User Badges:
  • Blue, 1500 points or more

Mohammed:


Sorry for the cross-post. Im glad you agree with me, though. :-)


Thanks


Victor

mohammedmahmoud Fri, 04/18/2008 - 10:26
User Badges:
  • Green, 3000 points or more

Hi Victor,


No problem :)


BR,

Mohammed Mahmoud.

Actions

This Discussion