UCM PRI Problem

Answered Question
Apr 20th, 2008

We are testing an AT&T PRI (Gateway is a 2821) which is controlled by UCM 6.0 via MGCP. We are sending the correct digits - verified by a debug isdn q931 - but get the following error: "Cause i = 0x83E020 - Mandatory information element missing". Anyone seen this error or have an idea of what to look for. We have tried a couple different protocols

NI2 and 4ESS along with various parameters on the gateway with no sucess. Thanks!

I have this problem too.
0 votes
Correct Answer by Jaime Valencia about 8 years 9 months ago

can u post the debug isdn q931 to look at all the IEs you're sending?

javalenc

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Jaime Valencia Sun, 04/20/2008 - 09:05

can u post the debug isdn q931 to look at all the IEs you're sending?

javalenc

mstafford Sun, 04/20/2008 - 09:28

Correction, this is what we're seeing:

Apr 20 03:53:59: ISDN Se0/0/1:23 Q931: TX -> SETUP pd = 8 callref = 0x0009

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98397

Exclusive, Channel 23

Calling Party Number i = 0x2181, '3037928854'

Plan:ISDN, Type:National

Called Party Number i = 0xA1, '6126643270'

Plan:ISDN, Type:National

Apr 20 03:53:59: ISDN Se0/0/1:23 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x8009

Cause i = 0x83E020

Sorry, This is all I captured...We tried ISDN, National, International IE's

Jaime Valencia Sun, 04/20/2008 - 10:02

try unknown, unknown

if still no avail id recommend to give a call to the telco to find out what they want. some telcos expect a specific plan and type for the calls

javalenc

mstafford Wed, 04/30/2008 - 19:37

Thanks! We tried the "isdn nsf-service sdn" command under the serial interface of the router, but this didn't help with outbound calls. Then we configured the "PRI 4ESS" switch type and "sdn" under the ISDN Parameters [in the long distance route pattern]. That fixed it!

Actions

This Discussion