Problem updating WLC from 4.1.185.0 to 5.0.148.0, help.

Unanswered Question
Apr 20th, 2008
User Badges:

Hello people


I tried to update my WLC 4402 from 4.1.185.0 to 5.0.148.0 and ran in to some trouble, this is

what I did:


1. Took backup of WLC (Commands -> Upload files -> uploaded config to a server)

2. Shut down WLANS

3. Downloaded AIR-WLC4400-K9-5-0-148-0.aes

4. Downloaded AIR-WLC4400-K9-5-0-148-0-ER.aes

5. Rebooted WLC

6. Downloaded config

7. After download of config the WLC automatically reset.


After this I couldn't access my WLC other than through the console. All settings were gone and

after fiddeling around for a while I realized that I could switch which image the WLC should boot

from, it looked like this:

1. 5.0.148.0 (active)

2. 4.1.185.0


I booted from image number 2 and restored my config, that worked fine, now my WLC is running again.

I set second image as active so it should automatically boot from that image if I reboot the WLC.


So now the boot list look like this:

1. 5.0.148.0

2. 4.1.185.0 (active)


My questions are:

If I would try updating again, from 4.1.185.0, would 4.1.185.0 be kept as the backup image again, so I

can restore if it doesn't work ? ie, would my boot list look like this:

1. 5.0.148.0 (active)

2. 4.1.185.0


Does anyone know what might have gone wrong ? I have a fealing that it's when I download the config

file that screws up the 5.0.148.0, could this be it ?


/Dan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Matthew Fowler Tue, 04/22/2008 - 17:18
User Badges:
  • Cisco Employee,

You are correct. All code before 4.2 uses binary configuration files, and code after 4.2 uses XML configuration files.


So, the WLC was expecting an XML file, but you uploaded a binary file, which resulted in the default settings.

hellbeach Wed, 04/23/2008 - 00:09
User Badges:

So if I updata again, will 4.1.185.0 still be kept as backup image ? (see my first post)

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode