3 ADSL connections on router 1841

Unanswered Question
Apr 21st, 2008

Hi,

I have a question regarding a 1841 router (2 FE ports) with 4-port ethernet switch card installed running IOS version 12.4(9)T1.

I have 2 ADSL through both FastEthernet ports, for Internet connection. Internal connection is provided through ethernet card.

Is it possible configure a third ADSL connection through another ethernet port of switch card?

Thanks in advance for any information,

Albert

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.
Sushil Kumar Katre Fri, 04/25/2008 - 09:40

Hi Albert,

I guess you are talking about HWIC-4ESW card, which is basically a Layer 2 etherswitch module.

Its not possible to assign IP Address directly on the physical interface.

Having said that, it supports Switched Virtual Interface SVI. So what you need to do is create a SVI, assign IP address on the SVI and associate that VLAN with the physical interface.

Thus the IP address would be associated with that Interface on which you can terminate the ADSL routers ethernet connection.

Create a VLAN -

vlan database

VLAN 22

Create SVI -

interface vlan 22

ip add 10.20.20.20 255.255.255.0

no shut

Assign the vlan to the physical interface -

interface FastEthernet 0/1/0

switchport access vlan 22

no shut

http://www.cisco.com/en/US/docs/ios/12_3t/12_3t8/feature/guide/esw_cfg.html#wp1051418

Now, you have terminated 3 ADSL routers on 1841 on the ethernet interfaces. Imagine the Main ADSL connectivity going down. Would your 1841 router be able to detect the link failure.

Not really the ethernet connection between 1841 and ADSL would remian UP doesn't matter if the main ADSL link is UP and down.

So the 1841 router would keep on sending the traffic to the failed link and packets would be dropped by the ADSL router.

How do you overcome this - Use SAA probes. It keeps on sending ICMP packets to the remote destination which has to be after your ADSL router. This SAA object needs to be associate with the "route" pointing towards that destination. When the ICMP reply packets are not received by the router the SAA object would go down and the route would be removed from the routing table.

I am not sure where these ADSL connecties are going, otherwise I could have been more specific.

-> Sushil

piotrlit07 Wed, 04/30/2008 - 01:03

Many thanks for your information. That guides me to next router configuration.

Albert

jfchang72 Thu, 05/01/2008 - 07:03

Hi Albert,

I'm not a CISCO expert but I'm trying configure something similar.

I have a 1841 router (2 FE ports) with 4-port ethernet switch card. I'm trying to configure FE 0/0 for ADSL with FIX IP and FE 0/1 with Dynamic IP. Both FE 0/0 & FE 0/1 connected to different modem provided by service provider. I also want to enable the load balancing / load sharing feature.

The 4-port ethernet switch card will be connect to LAN.

Can you tell me how to do it?

Thank you in advance,

Chang

E-mail : [email protected]

jfchang72 Sun, 05/04/2008 - 05:18

Thanks for your reply. I manage to setup vlan1 and DHCP for FE/0/0/0 - FE/0/0/3, and configure IP for both FE 0/0 & FE 0/1. Following is my setting...

Building configuration...

Current configuration : 2768 bytes

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname FABER

!

boot-start-marker

boot-end-marker

!

security authentication failure rate 3 log

security passwords min-length 6

logging buffered 51200 debugging

logging console critical

enable secret xxx

!

no aaa new-model

!

resource policy

!

clock timezone PCTime 8

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

no ip source-route

ip cef

!

!

ip tcp synwait-time 10

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1

ip dhcp excluded-address 20.20.20.255 20.255.255.254

ip dhcp excluded-address 20.0.0.1 20.20.20.9

!

ip dhcp pool sdm-pool1

import all

network 20.0.0.0 255.0.0.0

default-router 20.20.20.1

dns-server 202.x.x.5 202.188.0.133

!

!

no ip bootp server

ip domain name yourdomain.com

ip name-server 202.188.1.5

ip name-server 202.188.0.133

!

username admin privilege 15 secret xxx

!

!

!

interface FastEthernet0/0

description $ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$$ETH-LAN$

ip address 192.168.100.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip route-cache flow

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/1

description $ES_WAN$$FW_OUTSIDE$$ETH-WAN$

ip address dhcp client-id FastEthernet0/1

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip route-cache flow

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/0/0

!

interface FastEthernet0/0/1

!

interface FastEthernet0/0/2

!

interface FastEthernet0/0/3

!

interface Vlan1

ip address 20.20.20.1 255.0.0.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip route-cache flow

!

ip classless

!

ip http server

ip http authentication local

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat pool DHCP 20.20.20.1 20.20.20.100 netmask 255.0.0.0

ip nat inside source list 1 interface FastEthernet0/1 overload

!

logging trap debugging

access-list 1 remark INSIDE_IF=FastEthernet0/0

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 20.20.20.0 0.0.0.255

no cdp run

!

control-plane

!

banner login ^CAuthorized access only!

Disconnect IMMEDIATELY if you are not an authorized user!^C

!

line con 0

login local

transport output telnet

line aux 0

login local

transport output telnet

line vty 0 4

privilege level 15

login local

transport input telnet

line vty 5 15

privilege level 15

login local

transport input telnet

!

scheduler allocate 4000 1000

end

I still don't know which part should I add in for the Load-balancing for FE 0/0 & FE 0/1.

Thanks in advanced...

Paolo Bevilacqua Sun, 05/04/2008 - 10:51

You need:

ip nat inside source list 1 interface FastEthernet0/0 overload

ip route 0.0.0.0 0.0.0.0

Hope this helps, please rate post if it does!

jfchang72 Tue, 05/13/2008 - 06:17

Hi,

Thanks for your reply. I'm not good at CISCO IOS Command prompt. Can I do it in Cisco SDM?

Actions

This Discussion