Problems with International calls, carrier not stripping our 011

Unanswered Question
Apr 21st, 2008

Carrier is seeing 9011011xxxxx, I ran a debug isdn q931 and it is showing as an international plan.

How do i resolve this problem? Carrier insist that we need to do something on our end. I did find this article but i don't know if it is relevant for our Call manager 6.0 business edition since the article was a fix back in 2006.

----------------

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080325e8e.shtml

Example 1

In this example, if a number starts with "4" and the type is "national", the rule adds "90" as a prefix. If the type is "international", the rule adds "900" as the prefix.

voice translation-rule 7

rule 1 /^4/ /904/ type national national

rule 2 /^4/ /9004/ type international international

router#test voice translation-rule 7 493456567 type national

Matched with rule 1

Original number: 493456567 Translated number: 90493456567

Original number type: national Translated number type: national

Original number plan: none Translated number plan: none

router#test voice translation-rule 7 493456567 type international

Matched with rule 2

Original number: 493456567 Translated number: 900493456567

Original number type: international Translated number type: international

Original number plan: none Translated number plan: noneThis is useful when telephone companies (Telcos) remove access codes on national and international numbers. You can add the correct prefix with the number type as a basis.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Brandon Buffin Mon, 04/21/2008 - 07:40

Are you using MGCP or H.323 on your gateway? Check the route pattern/route list that the call is using for any digit manipulation. Can you post your gateway config?

Brandon

Brandon Buffin Mon, 04/21/2008 - 08:41

Yes, you are using H.323. It appears that your international call will hit dial peer 9292. Check your route pattern/route list on CCM to see how the digits are being manipulated for international calls. I'm guessing that you'll find that CCM is prefixing these digits before sending to the gateway.

Brandon

shirwaziri1_2 Mon, 04/21/2008 - 08:51

YEs, the call manager manipulates the internalal digits as follows:

stips 9011!

now, should I modify cm or modify voice gateway and the dial-peer

if so what do I manipulate?

dial-peer voice 9292 pots

destination-pattern 9.T

incoming called-number .

direct-inward-dial

port 0/3/0:23

Brandon Buffin Mon, 04/21/2008 - 09:08

So, if the carrier is seeing 9011011xxxxx, it would appear that CCM is stripping the 9 and then adding 9011. Assuming your route pattern is 9011! and with a dial peer of 9T on the gateway, you do not need CCM to do any digit manipluation. It will simply send the digits to the gateway and the gateway will strip the 9. With POTS dial peers, any explicitly matched digits are stripped.

Hope this helps.

Brandon

shirwaziri1_2 Mon, 04/21/2008 - 09:19

Do i just delete the number minipulation in the CM? Or change the digits to something else?

Brandon Buffin Mon, 04/21/2008 - 09:20

Assuming the route pattern sends calls only out this particular gateway, you can remove any digit manipulation.

Brandon

shirwaziri1_2 Mon, 04/21/2008 - 10:12

Last question. The only digit manipulation is the Route Pattern. (9011!)

That is a required field. I cannot delete that, should I change it to something else?

Brandon Buffin Mon, 04/21/2008 - 10:17

No called party transformations? Anything for Discard Digits? Check the route list under route list details as well.

Brandon

shirwaziri1_2 Mon, 04/21/2008 - 10:26

Ok, then in this case, there is nothing for digits discard. Not in the route pattern or in the route list details.

I do notice one thing, the ISDN network Specific facitilties info is missing. I attached a screen shot. ANy other ideas?

Oh yeah..Thanks for all your help with this.

Attachment: 
Brandon Buffin Mon, 04/21/2008 - 10:32

If you do the following on the gateway, do you see the call hit dial peer 9292. What is the called number?

router#term mon

router#debug voip dialpeer

You can post the output if you would like.

Brandon

shirwaziri1_2 Mon, 04/21/2008 - 10:37

Here is the output...looks like it is hitting the dialpeer. Called number is 9011442079864256

*Apr 21 18:34:58.479: //-1/001F6CAB5007/DPM/dpAssociateIncomingPeerCore:

Calling Number=5853256880, Called Number=9011442079864256, Voice-Interface=0x

0,

Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

Peer Info Type=DIALPEER_INFO_SPEECH

*Apr 21 18:34:58.483: //-1/001F6CAB5007/DPM/dpAssociateIncomingPeerCore:

Result=Success(0) after DP_MATCH_INCOMING_DNIS; Incoming Dial-peer=1212

*Apr 21 18:34:58.483: //-1/001F6CAB5007/DPM/dpAssociateIncomingPeerCore:

Calling Number=5853256880, Called Number=9011442079864256, Voice-Interface=0x

0,

Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

Peer Info Type=DIALPEER_INFO_SPEECH

*Apr 21 18:34:58.483: //-1/001F6CAB5007/DPM/dpAssociateIncomingPeerCore:

Result=Success(0) after DP_MATCH_INCOMING_DNIS; Incoming Dial-peer=1212

*Apr 21 18:34:58.483: //-1/001F6CAB5007/DPM/dpMatchPeersCore:

Calling Number=, Called Number=9011442079864256, Peer Info Type=DIALPEER_INFO

_SPEECH

*Apr 21 18:34:58.483: //-1/001F6CAB5007/DPM/dpMatchPeersCore:

Match Rule=DP_MATCH_DEST; Called Number=9011442079864256

*Apr 21 18:34:58.483: //-1/001F6CAB5007/DPM/dpMatchPeersCore:

Result=Success(0) after DP_MATCH_DEST

*Apr 21 18:34:58.483: //-1/001F6CAB5007/DPM/dpMatchPeersMoreArg:

Result=SUCCESS(0)

List of Matched Outgoing Dial-peer(s):

1: Dial-peer Tag=9292

*Apr 21 18:34:58.527: %ISDN-6-DISCONNECT: Interface Serial0/3/0:20 disconnected

from 15859876940 , call lasted 3 seconds

MN-2821Voice#

MN-2821Voice#

MN-2821Voice#term no mon

MN-2821Voice#una ll

^

% Invalid input detected at '^' marker.

MN-2821Voice#un all

Port Statistics for unclassified packets is not turned on.

All possible debugging has been turned off

MN-2821Voice#

Brandon Buffin Mon, 04/21/2008 - 10:48

The called number appears to be in the proper format and hitting the proper dial peer. Try changing the destination pattern from "9.T" to "9T".

Brandon

dinorubio Mon, 04/21/2008 - 08:50

on the dial-peer 9292 try this:

destination-pattern 9T

prefix 9011011

just a guess...

Actions

This Discussion