How do I trunk a 3550 and a 3750

Answered Question
Apr 21st, 2008

Hi Guys,

I have a 3750 sw and in there, vlan 5 is my data vlan. One server is plugged into one of the ports and this is the config for that port:

interface GigabitEthernet1/0/13

description Domain controller

switchport access vlan 5

switchport mode access

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust device cisco-phone

mls qos trust cos

macro description cisco-desktop

auto qos voip cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable

end

A 3550 sw has been plugged into port gi1/0/7 of this 3750. Here is the config for this gi1/0/7 port on the 3750:

interface GigabitEthernet1/0/7

description ********** Trunk to 3550 Switch **********

switchport access vlan 5

switchport mode access

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust device cisco-phone

mls qos trust cos

macro description cisco-desktop

auto qos voip cisco-phone

spanning-tree portfast

end

Here is the config for the 3550 port which connects to the 3750:

interface FastEthernet0/48

description 3550SW1 --- DOT1.Q ---- 3550SW2

switchport trunk encapsulation dot1q

switchport trunk native vlan 44

switchport trunk allowed vlan 44

switchport mode dynamic desirable

no ip address

duplex full

speed 100

end

This 3550 SW has been connected to the 3750 switch with the purpose of having all its ports (the 3550 ports) be in the same data vlan as that of the port Gi1/0/13 of the 3750.

How do I accomplish this? I know there some work to be done here.

Thanks in advanced

I have this problem too.
0 votes
Correct Answer by Richard Burts about 8 years 9 months ago

Angel

I believe that what you have configured on the interface of the 3550 is fine. And the other port configuration should be ok. I think that there are some issues with the configuration of the interface on the 3750. There are elements of the 3750 interface configuration that make good sense when it is to connect to and end station but not so much when it connects to another switch. In particular I believe that the various statements about port security will be problematic when connecting to another switch and I suggest that you remove them. Also the statements for qos and srr-queue are more appropriate for an end station connection than they are for a connection to another switch. And portfast is more appropriate for an end station than for a switch.

HTH

Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
lamav Mon, 04/21/2008 - 17:36

Hi:

I think what you're saying is that you would like to span one data vlan (vlan 5) across two switches.

Is that correct?

If so, you can do it 2 ways:

1.) Configure vlan 5 on the 3550, place the switch ports in that vlan, configure a trunk port and allow vlan 5 across it to the 3750.

-- OR --

2.) Configure vlan 5 on the 3550, place the switch ports in that vlan, but instead of configuring a trunk, you can configure the port that will connect to the 3750 as an access port that will be placed in vlan 5.

Whichever approach you take, both switches should have their inter-connectibng ports configured the same way: either as trunk ports ar as access ports, but not a mix and match.

HTH

Victor

insccisco Mon, 04/21/2008 - 17:50

The 3750 already has vlan 5 setup there. Here is the config for vlan 5 in the 3750:

interface Vlan5

description data vlan

ip address 10.242.5.1 255.255.255.0

ip pim sparse-dense-mode

end

The plan is that there were no more ports left in the 3750. So we sacrified one to connect the 3550. And on that 3550, all ports will belong to the vlan 5 so they can all communicate with the server already connected into Gi1/0/13 of the 3750.

lamav Mon, 04/21/2008 - 18:10

I figured you had vlan 5 already configured on the 3750, that's why I asked you to configure it in the 3550, not the 3750.

(I see vlan 44 on the 3550...what is that?)

If the 3750 is supporting the L2 and L3 components of vlan 5 (L2 switch ports and SVI)then just configure the 3550 for vlan 5, place the ports in it, and either trunk the two switches, or use option 2 above.

I hope Im not misunderstanding you.

Victor

Richard Burts Tue, 04/22/2008 - 04:22

Angel

There is a mismatch in your config since the port on the 3750 is configured as an access port but the connected port on the 3550 is configured as a trunk. From your description it seems that you should configure the port on the 3550 as an access port and not as a trunk port.

If the port on the 3550 is configured as an access port, and if all the ports on the 3550 are configured to be in the same VLAN (VLAN 5) then the objective of having all ports on the 3550 communicate with the server in VLAN 5 of the 3750 will be accomplished.

As Victor points out the configuration of the 3550 includes logic for VLAN 44. Your description of the 3550 indicates that all its ports should be in VLAN 5 (if I have correctly understood your description). Can you clarify what is going on in the 3550?

HTH

Rick

insccisco Tue, 04/22/2008 - 05:03

Yes, all those ports on the 3550 should not be in vlan 44 anymore. This 3550 sw was brought in from a branch office, so it still has that old config.

But can you help me fix that configuration on that 3550 port? what are the exact commands that I should setup in that 3550 port so I can make it an access port?

Richard Burts Tue, 04/22/2008 - 07:34

Angel

You should clear most of the old config (especially the interface configurations) and then configure for the new situation. The most important commands that you would need on the interface of the 3550 would be:

switchport access vlan 5

switchport mode access

HTH

Rick

insccisco Tue, 04/22/2008 - 08:20

I have the 3550 SW configured as follows (this is the port that connecst this 3550 to the 3750)

interface FastEthernet0/48

description ********** Link to 3750 Switch **********

switchport access vlan 5

switchport mode access

no ip address

duplex full

speed 100

end

On the 3750 SW, the port that connects this 3750 to the 3550 is configured as follows:

interface GigabitEthernet1/0/7

description ********** Trunk to 3550 Switch **********

switchport access vlan 5

switchport mode access

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust device cisco-phone

mls qos trust cos

macro description cisco-desktop

auto qos voip cisco-phone

spanning-tree portfast

end

Let me know if this is OK?

I will assume that on the 3550, all ports from fas0/1 to fas0/47 should be configured as follows:

switchport access vlan 5

switchport mode access

Let me know if this is correct

thanks

Correct Answer
Richard Burts Tue, 04/22/2008 - 10:41

Angel

I believe that what you have configured on the interface of the 3550 is fine. And the other port configuration should be ok. I think that there are some issues with the configuration of the interface on the 3750. There are elements of the 3750 interface configuration that make good sense when it is to connect to and end station but not so much when it connects to another switch. In particular I believe that the various statements about port security will be problematic when connecting to another switch and I suggest that you remove them. Also the statements for qos and srr-queue are more appropriate for an end station connection than they are for a connection to another switch. And portfast is more appropriate for an end station than for a switch.

HTH

Rick

insccisco Mon, 04/28/2008 - 12:21

Hi Rick, you were right. Sorry for not getting back sooner.

I ended up calling cisco and it gave tac engineers some headaches and at the end, it was determined that the port-security statements, just like you had advised, were very problematic. The port on this 3750 had to be set back to factory defaults.

Now all is golden.

As always, thank you very much rick

Richard Burts Mon, 04/28/2008 - 12:55

Angel

I am glad that you got it resolved and that ultimately my suggestion turned out to be correct. It is never a bad idea to get Cisco TAC involved when there is a problem and you are not sure what is involved. I am glad that TAC saw it the same way that I did.

Thank you for using the rating system to indicate that your problem was resolved (and thanks for the rating). It makes the forum more useful when people can read about a problem and can know that there was a response which did resolve the problem.

The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum.

HTH

Rick

insccisco Mon, 04/28/2008 - 13:02

no doubt. this forum is invaluable

Speaking about that, what places or perhaps parts of this forum do you recommend for helping with your CCNA exams?

I am now preparing for it and need to find all types of helps.

thanks

Richard Burts Mon, 04/28/2008 - 13:12

Angel

There is a certifications section of the forum. I believe that this would be the most appropriate form for most of your CCNA certification questions.

good luck with your CCNA.

HTH

Rick

Actions

This Discussion