vg224 flashcard problem

Unanswered Question

Hi! I have a strange problem with my vg224. I see this message during boot:

flash: CompactFlash not present.

And my vg224 boot in rommon. But I can see flashcard like slot0, I can normaly boot router from rommon:

rommon> boot slot0:vg224.bin

I cann't do "dir flash:" - no such device.

So, how can I repair flash: ?

I see bug about flashcards and already upgraded rommon, but problem still exist.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
amritpatek Mon, 04/28/2008 - 05:54

First try just running "boot" from Rommon to see if it can find a good image. If this does not work, the next step is to try formatting slot0 from the VG224. Bad magic number usually means that the devices was formatted or had images copied to it from a different hardware platform or PC. Then you have to put the image back onto the flash card by using a different VG224 if you have one available to use. Use the instructions at the following site to download the image to the router using tftp or xmodem:

ccna-viva Fri, 04/23/2010 - 06:17

i had similar problem,

in rommon first enter confreg 0x2102

then in rommon enter confreg with no parameters and it wil enter setup mode.

answer all parameters with no and reset.

in my case it worked!

saif musa Mon, 10/21/2013 - 03:36

I had similar issue and I cover it  by entering command : confreg 0x2102

now it works fine

thanks alote for helping me with those usfull posts


This Discussion