How Upgrade Cisco 1250 from autonomous mode to LWAP

Answered Question
Apr 22nd, 2008

I look on the option upgrade Cisco 1250 AP (AIR-AP1252AG-I-K9 ) from IOS version to LWAP.

Cisco Upgrade utility ver 3.2 not supported WAP 1250 series.

What is process to upgrade Cisco 1250 from autonomous mode to LWAP

I have this problem too.
0 votes
Correct Answer by Matthew Fowler about 8 years 7 months ago

Edit: beaten! 5 for Scott.

All of the 1252's have Manufacture Installed Certificate (MIC), so the tool isn't really needed anyway.

Just download the recovery image (c1250-rcvk9w8) and use the archive command (archive download-sw

tftp:///). The difference will be that the WLC information will not be on this converted AP. So, if it is on a different subnet than the management interface of the WLC, you will need to set up either DHCP option 43, DNS resolution or staticly configure it; as per the deployment guide (http://www.cisco.com/en/US/docs/wireless/technology/controller/deployment/guide/dep.html).

Correct Answer by Scott Fella about 8 years 7 months ago

You have to use the archive command to upgrade to lwapp. Have the ap obtain an ip address and then telnet or console into the ap and run the command.

archive download-sw /force-reload /overwrite tftp://10.0.0.1/image-name

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Correct Answer
Scott Fella Tue, 04/22/2008 - 16:42

You have to use the archive command to upgrade to lwapp. Have the ap obtain an ip address and then telnet or console into the ap and run the command.

archive download-sw /force-reload /overwrite tftp://10.0.0.1/image-name

Correct Answer
Matthew Fowler Tue, 04/22/2008 - 16:50

Edit: beaten! 5 for Scott.

All of the 1252's have Manufacture Installed Certificate (MIC), so the tool isn't really needed anyway.

Just download the recovery image (c1250-rcvk9w8) and use the archive command (archive download-sw

tftp:///). The difference will be that the WLC information will not be on this converted AP. So, if it is on a different subnet than the management interface of the WLC, you will need to set up either DHCP option 43, DNS resolution or staticly configure it; as per the deployment guide (http://www.cisco.com/en/US/docs/wireless/technology/controller/deployment/guide/dep.html).

Scott Fella Tue, 04/22/2008 - 16:55

Hahaha....

Had to run this for 100 1252 that we only could get in Autonomous.....

I better know this.

vpergament Wed, 04/23/2008 - 03:35

Thank you very much for your answer.

I upgrade 1252 with new c1250-rcvk9w8-tar.124-10b.JA3 microcode. as you talked upgrade was easy but after restart AP can't upgrade image from controller .

I received next error messaging

% The key modulus size is 1024 bits

% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

ip ssh version 2

^

% Invalid input detected at '^' marker.

transport input ssh

^

% Invalid input detected at '^' marker.

...............

examining image...

%LWAPP-5-CHANGED: LWAPP changed state to JOIN

%LWAPP-5-CHANGED: LWAPP changed state to IMAGE

transport input ssh

^

% Invalid input detected at '^' marker.

%Error opening (Protocol error)

archive download: takes 6 seconds

%LWAPP-3-CLIENTERRORLOG: Retransmission count for packet exceeded max(IMAGE_DATA

, 1)

%LWAPP-5-CHANGED:

FYI:

I use 4402 controler ver 4.1

Do you have any suggestions ?

Attachment: 
vpergament Wed, 04/23/2008 - 08:54

Hello,

in the debug mode I found that controller ver 4.1 dooesnt support Wireless AP 1252

debug logs

------------------------------------

Wed Apr 23 14:36:17 2008: 00:1e:7a:81:55:50 Refusing image download to unsupported AP 00:1e:7a:81:55:50

Wed Apr 23 14:36:17 2008: 00:1e:7a:81:55:50 Processing of Image Data failed from AP 00:1e:7a:81:55:50

Wed Apr 23 14:36:18 2008: 00:1e:7a:81:55:50 Received Image Data from unknown AP 00:1e:7a:81:55:50

----------------------------------------

After I have upgraded controller to version 5.0. WAP 1250 succsesfuly registred on the controller.

Thank you very much for help

loretomarquez Tue, 06/10/2008 - 00:24

Hi vpergament,

I had the same problem, and now I have to update from 4.1 to 5.0. Did you find any problem upgrading directly from one version to the other? Is there any procedure in cisco.com for doing that?

Thanks in advance.

vpergament Tue, 06/10/2008 - 02:06

Hi

I agree with Pradeep , that need to be careful and read upgrade instruction . If I am not mistake for upgrade from 4.1 to 5 you need minimum controller version 4.1.191.24.

loretomarquez Tue, 06/10/2008 - 03:28

Hi,

The one that I have is 4.1.171.0 and in table 1 of the document that Pradeep mentioned we can see that we can upgrade directly from this versión. I will tell you with the results.

Thanks to everybody.

Scott Pickles Wed, 04/22/2009 - 12:21

Scott -

Too bad you don't know perl - I would write a script to do this for you. With a 48 port PoE switch you could do something on the order of 20-30 at a time, assuming the switch has enough power for that.

Regards,

Scott

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode