vlan routing

Unanswered Question
Apr 23rd, 2008
User Badges:

Hi. I configured my router interface for vlan routing. However I am unable to ping any of these subinterfaces from the router itself and when i run: sh ip int brief, it shows e0 as up up but e0.1 and e0.2 as down.

The config of the interface is shown below.


int e0

no shut


int e0.1

ip add 10.0.1.1 255.255.255.0

encap dot1q 2

no shut


int e0.2

ip add 10.0.2.1 255.255.255.0

encap dot1q 3

no shut


When i go to check e0.1 or e0.2, it shows a status as up but protocol down. e0 is physically connected to a switch port f0/12. The config is shown below.


int f0/12

switchport mode trunk

switchport trunk encap dot1q

no shut


This switch has two vlans- 2 and 3. Also, i checked the BW of f0/12 and e0 and found it to be set to 10MB. I manually set the bandwidth of e0.1 and e0.2 to 10MB as well but still no go.


I do hope someone can help me with this. Thanks.




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dezoconnor Wed, 04/23/2008 - 02:31
User Badges:
  • Silver, 250 points or more

Have you created the vlan's themselves on the switch, are they in the vlan database if you do a show vlan?


If not, type conf t, vlan2, exit, vlan3


HTH



smothuku Wed, 04/23/2008 - 02:37
User Badges:
  • Silver, 250 points or more

Hi ,


Can you change the config as below and check the status of interfaces.


int e0

no shut


int e0.1

ip add 10.0.1.1 255.255.255.0

encap dot1q 2 native

no shut


int e0.2

ip add 10.0.2.1 255.255.255.0

encap dot1q 3

no shut


Switch :


interface vlan 2

ip address 10.0.1.253 255.255.255.0

no sh


int f0/12

switchport mode trunk

switchport trunk native vlan 2

speed 100

duplex full

no shut


ip default-gateway 10.0.1.1


Thanks,

Satish




marcusbrutus Wed, 04/23/2008 - 06:08
User Badges:

Hi Satish. Just wish to ask: shouldn't i be able to ping e0.1 and e0.2 from the router?

padramas Wed, 04/23/2008 - 15:27
User Badges:
  • Cisco Employee,

Hello Mark,

Can you share with us IOS image information on router?


Padmanabhan


Actions

This Discussion