R2 MFC Avaya to Cisco 2801 [one way ANI issue]

Unanswered Question
Apr 23rd, 2008
User Badges:

Hi All,


Today i am doing a POC to test R2 interoperability between Cisco 2801 (VWIC-2MFT-E1-DI + VIC2-2FXS + CP-7940) with Lucent Definity G3 PBX. I used and followed config guide from http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis3600/sw_conf/pbx_int/36lde1r2.pdf


The results are:

1. Voice call from Cisco to Avaya is working, but Cisco's ANI is not shown on Lucent Phone instead it shows Avaya TAC number & trunk name.

2. Voice call from Avaya to Cisco is also working and Avaya's ANI is shown on Cisco IP Phone.


The issue is Avaya's ANI is not shown on Cisco IP Phone.


We asked Avaya's engineer to make a change on Multifrequency-Signaling-Related System Parameters -> request incoming ANI (non-AAR/ASR) to 'y' (Cisco config guide set 'n'). For detailed change see attachment


After tested call from Cisco to AVAYA, call setup took about 10 seconds to connect (before, it only takes less than 3 seconds) however Cisco' ANI is now appear on Lucent Phone.


I used debug to capture the message between them. Here the log.


Apr 22 20:48:16.866: R2 Outgoing Voice(0/0): DSX (E1 0/1/0:28): STATE: R2_OUT_PROCESS_A R2 Got Event R2_TONE_OFF

Apr 22 20:48:16.866: r2_reg_generate_digits(0/1/0:1(29)): Tx digit 'B'

Apr 22 20:48:25.018: htsp_dialing_done(0/1/0:1(29))

Apr 22 20:48:27.398: htsp_digit_ready_up(0/1/0:1(29)): Rx digit='3'

Apr 22 20:48:27.398: R2 Outgoing Voice(0/0): DSX (E1 0/1/0:28): STATE: R2_OUT_PROCESS_A R2 Got Event 3


From message above, on time stamp Apr 22 20:48:16.866, Cisco sends Tx digit 'B' to Avaya, but avaya sends response Rx digit='3' around 10 seconds later.


My questions are:

1. What is Tx digit 'B'? why Cisco sends alphabet as digit instead of numeric? i guess Avaya doesn't understand this. That's why it takes 10 seconds to make respond.

2. Can we modify Tx digit 'B' setting? if not is there ways how to speed up call setup?


Anybody has ever had this issue? Appreciated if somebody could help.


Regards,

Edi



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
edi_hamlet Wed, 04/23/2008 - 02:47
User Badges:

Hi All,


I want to make correction. I said on previous email, The issue is Avaya's ANI is not shown on Cisco IP Phone. The correct issue is Cisco' ANI is not shown on Lucent phone.


sorry for this misunderstanding.


Regards,

Edi

paolo bevilacqua Wed, 04/23/2008 - 04:08
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, when you configure ANI, it takes a lot of time to be sent. Are you using compelled signaling ? Withi non-compelled it "might" be faster as you don't need to wait for the other party to acknowledge each digit.

edi_hamlet Wed, 04/23/2008 - 04:31
User Badges:

Hi,


E1 controller config:

!

controller E1 0/1/0

framing NO-CRC4

ds0-group 1 timeslots 1-15,17-31 type r2-analog r2-compelled ani

cas-custom 1

country argentina use-defaults

metering

!


When I change to non-compelled, calls can't established at all.

paolo bevilacqua Wed, 04/23/2008 - 04:38
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

The thing is that ANI takes a long time to be sent. You can visualize that with "debug vpm signal" and "term mon" see how many digits are sent, and the total time for that.

Either you remove ANI, make the ANI shorter, or configure the avaya for non-compelled that is faster.

edi_hamlet Wed, 04/23/2008 - 04:58
User Badges:

Hi,


Thanks for your suggestions. We will consider to try it.


Anyway, after make change on Incoming MFC Forward Signal I-12 to 'end-of-ani' (which is not wrote in Cisco guide) on Avaya PBX then everything is now going fine. ANI is now appear on both Cisco and Lucent phone.


Many thanks...

paolo bevilacqua Wed, 04/23/2008 - 07:37
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Good to know, thanks for the update!

Actions

This Discussion