Device discovery/data collection & ATA186

Unanswered Question
Apr 23rd, 2008

I have a huge difference between discovered and collected devices in CM (422/275). It turns out that most of the difference consists of our ATA186 boxes showing up as discovered devices but not collected since they are not on a VLAN accesible to CM. No phones show up, only ATA186. Any ideas why and how we can work around this little annoyance?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Joe Clarke Wed, 04/23/2008 - 08:05

IP phones are ignored by Discovery and Data Collection since they are not SNMP reachable. ATA186 devices are not listed in the ignored list. You could define Discovery filters to ignore the IP addresses of ATA186 devices. This would keep them from showing up in the list.

ratatosk_2 Wed, 04/23/2008 - 08:37

I saw the part about snmp and IPT in the other thread too but they are in fact also unreachable in our design as well. Anyhow I thought about the filtering possibility but how come the ATA186 is not on the ignore list? Are they snmp enabled normally? If not, will this be corrected or can I add it to the ignore list somehow? It would be a better permanent solution I think compared to maintaining a list of (DHCP, changing) IP:s for all the ATA:s.

Joe Clarke Wed, 04/23/2008 - 08:43

I doubt the ATA186's will be added to the ignore list since Discovery has moved out of Campus into Common Services. The next release of CS Discovery will do a more thorough job of ignoring VoIP devices.

I'm not sure if the ATA186's can be made to answer SNMP queries. You could add their CDP ID to NMSROOT/campus/etc/cwsi/ANIDevice.properties, and this would effectively ignore these devices.

ratatosk_2 Wed, 04/23/2008 - 09:07

Ok, I'll try that! Thanks! :)

I saw this in other places too, discovery moving from cm to cs. This is happening in what release? At least in GUI I still get discovery in CM (running the latest versions of 3.0 downloadable).

Joe Clarke Wed, 04/23/2008 - 09:24

LMS 3.0.1 (latest available now) no longer contains CM Discovery. Discovery is now found under Common Services > Device and Credentials > Device Discovery.

ratatosk_2 Wed, 04/23/2008 - 09:39

Wow! That hack with the ANIdevice.properties file really sorted my problem! I could even weed out our provider's 1812:s since we only have 1811:s :)

Ok... I just ran Software Center and it does not tell me there is a 3.0.1, ok. I guess it is a free upgrade since it is a minor version?

ratatosk_2 Thu, 05/08/2008 - 03:36

Hello again :) I just installed the December 2007 update (3.0.1) and now I have more unreachable devices than ever before. In the range of 1500 and growing. The device discovery has been running since 07.00a.m and now at 01.30p.m it is still not done! It seems like all the IPT devices, not just the ATA:s are turning up. Can I just add the cdp id of the phones to the ANIdevices.properties or is there a better way in this new release of device discovery? No layer 3 detection is selected in the prefs, just cdp.

Joe Clarke Thu, 05/08/2008 - 06:39

ANIDevice.properties is no longer relevant. This is another bug in the new Common Services discovery, CSCsm13114. The workaround is to exclude the ranges for devices which support CDP but do not support SNMP. This bug will be fixed in LMS 3.1.

ratatosk_2 Fri, 05/09/2008 - 00:24

Ok, thanks, not what I wanted to hear but anyway :) I'm adding filters. Is there a road map for CW software development or a release date for 3.1 available?

Actions

This Discussion