OSI 3rd layer and some other questions

Unanswered Question
Apr 23rd, 2008

Hello, i just did a quick review on my CCNA material and it has risen me a few questions:

1)I know you have IP and the 3rd OSI layer - but why do we really need it? we have unique MAC addresses for every NIC so that should be enough, so why do we need IP after all?

2)Same goes for subnets - why do we need them? what is their main purpose?

3)Suppose i have some basic Router topology going on - i mean, i have set it all up but didn't turn it on and let it work. so at the moment i do let it work suppose some end-point computer wants to send data to another computer that is on a different subnet\LAN - how does the router acquire the information needed for his route-table. i dont quite agree with route-updates(in case the routing protocol is distance vector) because as i understand it send UPDATES but there is nothing to update because first the information should be acquired..(and what about link-state and hybrid?)

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jason Fraioli Wed, 04/23/2008 - 11:52

Question 3:

1.) Computer A trys to communicate with a Computer B not on it's subnet.

2.) Computer A sends a packet to it's default gateway

3.) The gateway then determines how to get to Computer B (routing)

4.) At the destination network, the switch arps for the mac address associated with the desination IP address in the packet.

5.) Computer B reverses the process to send back to Computer A

Question 1 should be answered by my answer 3.

Question 2: Subnets conserve IP address space. For a point to point connection, why waste an entire classfull network (/24) when you can use just a portion of that classfull network?

Edit: I'm not sure if you are asking how routing takes place, but if you are I guess I failed to answer it so I will attempt to do so now.

Routing is based on, you guessed it, routes. These can be manually configured or dynamically learned. You might think of basic routing like you would a DNS hierarchy.

ip route network1/subnet via interface 1

ip route network1/subnet via interface 2

ip route 0.0.0.0 0.0.0.0 via interface 3

In this example, the router knows about two directly connected networks that it can route to. The last line is a "catch-all" which basically says, if all configured/learned routes are no good for the destination I am trying to reach, use this one and let someone elses router find the destination.

As for link-state and hybrid, those types will handle routing updates differently but it all boils down to the same thing. They know about directly connected networks which they can then let other connected routers know about. If "all else fails" they can use a default route and let someone elses router find the destination IP.

milkdroogy Wed, 04/23/2008 - 13:16

You didnt explain the reason we need IP, why cant we do all that with MAC's and layer 2?

about the routing - i just want to know what happens if i send some data to a subnet/LAN that is not found in the router's routing-table, how does he acquire it? how does the process goes?

padramas Wed, 04/23/2008 - 15:59

>> the reason we need IP, why cant we do all that with MAC's and layer 2?

There are many design related considerations over IP addresses and Layer 2( MAC addresses).

* IP addresses are structured to provide hierarchical scheme which adds features like scalability and management. Standard analogy are telephone numbers

* IP addresses are associated with node

Layer 2 MAC addresses

* They are not structured

* They are associated with adapter i.e. hardware

* Helps in communication with a node that are connected via broadcast network medium.

Regarding your question on routing, If I understand correctly, a packet destined to a network that is not in the routing table, the router will drop it.

Populating routing table information is taken care of by static entries or dynamic routing protocols.

HTH

Padmanabhan

milkdroogy Wed, 04/23/2008 - 20:26

Yes but how does the routing protocol do it?

You must agree that it wont drop those packets forever..how does he acquire this route?(regarding RIP,OSPF,IGRP and EIGRP)

Jason Fraioli Thu, 04/24/2008 - 03:36

Are you asking how each individual routing protocol communicates its routes/changes to other routers?

Question: "how does he acquire this route?(regarding RIP,OSPF,IGRP and EIGRP)"

Routers know about directly connected networks, if you choose to populate those networks in a routing protocol, then you have the possibility of other directly connected routers "learning" about the original routers routes.

In the below example, router 1 and 2 will learn about each others 192.168.x.0 network via RIP. The key is advertising your connected networks to other routers.

You can also configure a static route for traffic that does not match up against a route already in the routing table.

ip route 0.0.0.0 0.0.0.0 fa1/1

Router1:

router rip

network 10.0.0.0

network 192.168.1.0

Router2:

router rip

network 10.0.0.0

network 192.168.2.0

milkdroogy Thu, 04/24/2008 - 05:01

"router 1 and 2 will learn about each others 192.168.x.0 network via RIP."

Yes, but HOW it will learn it?

Jason Fraioli Thu, 04/24/2008 - 06:43

RIP sends out routing update messages every 30 seconds, or when the network topology changes. Max hop count on RIP is 15, if you hit 16 then the destination network is considered unreachable.

milkdroogy Sun, 04/27/2008 - 01:11

yes but you have a complete unknown subnet/LAN so how RIP can send its updates to that destination?

Actions

This Discussion