WAAS and print drivers

Answered Question
Apr 23rd, 2008
User Badges:

Has anyone had success in connecting Canon multi-function printers to a WAAS print queue that is available to clients?


I can create the queue and attach to it through a client, but the Windows status constantly states "Access denied, unable to connect". I can still print to it but I can't get a status on jobs either.


I've gone through the steps of registering with Kerberos to a Win2k3 DC and that all works great.


In addition, I cannot find any Canon drivers that will work with the WAAS as a print server for automatic download to a client. For instance, I have a "Canon iR2200-3300 PS3" driver associated with my print server and a printer.


Every time I try to connect a client to this test printer, I have to manually install a printer driver from the client instead of getting the auto-download from the EDGE WAE. What a pain!


Anyone else experience this as well???



Thanks,


DK

Correct Answer by Zach Seils about 9 years 1 day ago

David,


You need to associate the driver that was uploaded to the WAE with the appropriate print queue. Here are the steps:



1. From Windows command prompt, connect to the WAE with administrative user:


net use \Print$ * /user:


2. Access the Print Server (Start->Run):


3. Open WAAS Print Server's 'Printers and Faxes' folder.


4. Right click on the shared printer.


5. At the bottom of the menu, select 'Properties'.


6. If asked to install Print Driver, choose NO.


7. Go to 'Advanced' tab.


8. Choose the relevant driver=s from the drop down list.


9. Click Apply.


10. Then click on 'Printing Defaults', to initialize the print driver.


11. Change 'Portrait' page setting to 'Landscape' click 'Apply'.


12. Change 'Landscape' back to 'Portrait' and click 'Apply'.


13. Optionally, you can change all other, relevant printing defaults, which will be applied to all future client driver installations.


14. Perform steps 8 to 13 for each driver that you wish to assign to that print server.


Zach



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Zach Seils Thu, 04/24/2008 - 08:57
User Badges:
  • Cisco Employee,

David,


What is the URI you have configured for the queue?


Zach

dkennedy99 Thu, 04/24/2008 - 09:35
User Badges:

Currently: http://10.100.8.25:631/ipp


I've also tried http://10.100.8.25:631 and socket:/10.100.8.25:9100. They both work and it prints but I just can't get queue info on the client side, nor can I automatically load the driver on the client. Must be manually installed. By the way, it's currently running a PCL6 driver. Works fine with it or a PS3 driver.

Zach Seils Fri, 04/25/2008 - 02:15
User Badges:
  • Cisco Employee,

David,


For the automatic driver download, have you uploaded the driver to the WAE and associated it with the print queue?


For the access denied issue, please configure the following:


smb-conf section "printers" name "use client driver" value "yes"


Zach



dkennedy99 Fri, 04/25/2008 - 07:41
User Badges:

Hmmm...I am showing the driver is downloaded to the Edge device, but not necessarily associated with the print queue.


In the GUI, under Services-Print-Servers-Printers, I am showing the print queue and the type (Standalone), but nothing under the Current Driver. However I do show, under Services-Print-Servers-Drivers, the download of a PS3 driver as 'completed'.


I have tried mapping the \\\print$ and adding the driver that way (manually, because it will not download automatically), but I still get "Access Denied, unable to connect".

dkennedy99 Mon, 04/28/2008 - 05:26
User Badges:

Any further ideas? I have tried the "smb-conf" command you mentioned earlier, but it had no effect.

Correct Answer
Zach Seils Mon, 04/28/2008 - 20:55
User Badges:
  • Cisco Employee,

David,


You need to associate the driver that was uploaded to the WAE with the appropriate print queue. Here are the steps:



1. From Windows command prompt, connect to the WAE with administrative user:


net use \Print$ * /user:


2. Access the Print Server (Start->Run):


3. Open WAAS Print Server's 'Printers and Faxes' folder.


4. Right click on the shared printer.


5. At the bottom of the menu, select 'Properties'.


6. If asked to install Print Driver, choose NO.


7. Go to 'Advanced' tab.


8. Choose the relevant driver=s from the drop down list.


9. Click Apply.


10. Then click on 'Printing Defaults', to initialize the print driver.


11. Change 'Portrait' page setting to 'Landscape' click 'Apply'.


12. Change 'Landscape' back to 'Portrait' and click 'Apply'.


13. Optionally, you can change all other, relevant printing defaults, which will be applied to all future client driver installations.


14. Perform steps 8 to 13 for each driver that you wish to assign to that print server.


Zach



dkennedy99 Mon, 04/28/2008 - 23:35
User Badges:

This worked. I don't know what I was doing wrong before, but my guess is the initialization of the driver.


The drivers are now properly associated with the print queue and it is working like a champ.


Thanks, Zach!


David

dkennedy99 Tue, 04/29/2008 - 06:35
User Badges:

I have connectivity from the clients to the printers now. But I am having a time working with the print_fix.exe utility to make the drivers work. I've run the print_diff.exe to get the differences documented. And then the print_fix.exe utility runs and states that several keys have been entered. However, I am unable to get it to print still.


I am using the Control manager as the repository as well as an FYI.


Any further suggestions?


Thanks,


David

Actions

This Discussion