frame switching home lab

Answered Question
Apr 23rd, 2008

i have a router acting as frame switch connecting to 4 routers via serial interface, the way it is set up,

r1 s 0/0 connected to frame swtich s 0/2, r2 s0/0 connected frame switch s 0/0, r3 s0/0 connected to frame switch s 0/1, r4 s0/0 connected to frame switch s 0/0. all the pvcs are active in the frame-switch.

The problem is i cant ping some of routers from some other routers.

r4 s 0/0 ip address 10.10.12.5 cant ping r1, r3, can only ping r2

r3 s 0/0 ip address 10.10.12.2 cant ping r4, r1, can only ping r2

r2 s 0/0 ip address 10.10.12.3 can ping r4, r3 & r1 (all the routers)

r1 s 0/0 ip address 10.10.12.4 cant ping r4, r3, can only ping r2.

I have spent lots of time trying to figure this out, but did not work out, any help will be very much appreciated. here is the frame-switch config:

ip subnet-zero

frame-relay switching

!

!

!

!

!

interface Ethernet0/0

ip address 7.0.0.1 255.255.255.252

no ip directed-broadcast

!

--More-- interface Serial0/0

no ip address

no ip directed-broadcast

encapsulation frame-relay

logging event subif-link-status

logging event dlci-status-change

clockrate 64000

no frame-relay inverse-arp

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 122 interface Serial0/1 221

frame-relay route 123 interface Serial0/2 321

frame-relay route 124 interface Serial0/3 421

!

interface TokenRing0/0

no ip address

no ip directed-broadcast

shutdown

ring-speed 16

!

interface Serial0/1

no ip address

no ip directed-broadcast

--More-- encapsulation frame-relay

logging event subif-link-status

logging event dlci-status-change

clockrate 64000

no frame-relay inverse-arp

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 221 interface Serial0/0 122

!

interface Serial0/2

no ip address

no ip directed-broadcast

encapsulation frame-relay

logging event subif-link-status

logging event dlci-status-change

clockrate 64000

no frame-relay inverse-arp

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 321 interface Serial0/0 123

!

interface Serial0/3

no ip address

--More-- no ip directed-broadcast

encapsulation frame-relay

logging event subif-link-status

logging event dlci-status-change

clockrate 64000

no frame-relay inverse-arp

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 421 interface Serial0/0 124

I have this problem too.
0 votes
Correct Answer by Kevin Dorrell about 8 years 9 months ago

You need to disable split horizon on your hub router R2. With split-horizon, R2 will not advertise a route out the same interface it came in on. So it will pass on advertisments spoke to spoke.

Disable split-horizon like this:

</p><p>int S0/0.1</p><p>  no ip split-horizon eigrp <i>n</i></p><p>

Substitute 'n' with your EIGRP AS number

Kevin Dorrell

Luxembourg

Correct Answer by Kevin Dorrell about 8 years 9 months ago

This seems clear to me. You only have three PVCs set up in your FR switch:

S0/0(122) <--> S0/1 (221)

S0/0(123) <--> S0/2 (321)

S0/0(124) <--> s0/3 (421)

Those are the PVC where the ping works. S0/0 (R2) is the hub and the other three ports are spokes. You have no spoke-to-spoke communication.

To ping spoke-to-spoke, you will have to configure frame maps for the spoke-to-spoke communication via the hub DLCI. For example on R1 S0/0,

</p><p>frame-relay map ip 10.10.12.3 321 broadcast</p><p>frame-relay map ip 10.10.12.2 321</p><p>frame-relay map ip 10.10.12.5 321</p><p>

Do this for all three spoke routers, modifying the addresses and DLCIs so that they address R2 with the DLCI and broadcast, plus each of the other two spokes with just the DLCI.

Alternatively, on each of the three spoke routers, create a point-to-point subinterface and configure the one DLCI on it. For example on R1:

</p><p>interface s0/0.1</p><p>  ip address 10.10.12.4 255.255.255.240</p><p>  frame-relay interface-dlci 321</p><p>

Do this for all three spoke routers. With a point-to-point subinterface, all the addresses in the subnet will be sent down the same DLCI, and there will be no need for frame maps.

Kevin Dorrell

Luxembourg

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
avillalva Wed, 04/23/2008 - 22:00

Your problem is frame relay inverse arp (it's disabled). I prefer to use the command frame-relay map ip broadcast on each serial interface, it's much more reliable. Don't forget is the ip address of the other side of the serial link.

Good luck,

Andres

mohammedmahmoud Thu, 04/24/2008 - 00:13

Hi,

No need for inverse-arp on the FRSW, i believe that this might be a configuration issue on the routers, can you please attach a file with all your frame-relay configurations.

BR,

Mohammed Mahmoud.

rajibchicago Thu, 04/24/2008 - 22:48

I disabled no frame-relay inverse-arp for all the routers including frsw. now

r4 can ping r2 only

r3 can ping r2 only

r2 can ping all routers

r1 can ping r2 only.

all the pvcs r up in frame-switch, if i run a sh frame-relay map command in r4,r3 & r1 this is out put i get:

Serial0/0 (up): ip 10.10.12.3 dlci 321(0x141,0x5010), dynamic,

broadcast,, status defined, active,

for r2 it shows all 3 of them.

I am kinda lost with this. thanks

Attachment: 
Correct Answer
Kevin Dorrell Fri, 04/25/2008 - 05:47

This seems clear to me. You only have three PVCs set up in your FR switch:

S0/0(122) <--> S0/1 (221)

S0/0(123) <--> S0/2 (321)

S0/0(124) <--> s0/3 (421)

Those are the PVC where the ping works. S0/0 (R2) is the hub and the other three ports are spokes. You have no spoke-to-spoke communication.

To ping spoke-to-spoke, you will have to configure frame maps for the spoke-to-spoke communication via the hub DLCI. For example on R1 S0/0,

</p><p>frame-relay map ip 10.10.12.3 321 broadcast</p><p>frame-relay map ip 10.10.12.2 321</p><p>frame-relay map ip 10.10.12.5 321</p><p>

Do this for all three spoke routers, modifying the addresses and DLCIs so that they address R2 with the DLCI and broadcast, plus each of the other two spokes with just the DLCI.

Alternatively, on each of the three spoke routers, create a point-to-point subinterface and configure the one DLCI on it. For example on R1:

</p><p>interface s0/0.1</p><p>  ip address 10.10.12.4 255.255.255.240</p><p>  frame-relay interface-dlci 321</p><p>

Do this for all three spoke routers. With a point-to-point subinterface, all the addresses in the subnet will be sent down the same DLCI, and there will be no need for frame maps.

Kevin Dorrell

Luxembourg

rajibchicago Fri, 04/25/2008 - 23:33

Kevin,

Thank you so much, that solved the problem. i used the frame-relay map ip command.

But now another question, r4 has 2 interfaces s0/0 10.10.12.5 & e0/0 5.0.3.1, r1 s0/0 10.10.12.4 & e0/0 192.168.1.65, r3 s0/0 10.10.12.2 & e0/0 10.10.30.1 i am running eigrp on all the routers. when i run show ip route, only r2 has route to all subnets, r4 does not have any route 192.168.1.0 & 10.10.30.0, r1 has no route to 5.0.3.0 & 10.10.30.0, r3 has no no route 5.0.3.0 & 192.168.1.0

thanks for your help

Correct Answer
Kevin Dorrell Sat, 04/26/2008 - 08:35

You need to disable split horizon on your hub router R2. With split-horizon, R2 will not advertise a route out the same interface it came in on. So it will pass on advertisments spoke to spoke.

Disable split-horizon like this:

</p><p>int S0/0.1</p><p>  no ip split-horizon eigrp <i>n</i></p><p>

Substitute 'n' with your EIGRP AS number

Kevin Dorrell

Luxembourg

Actions

This Discussion