VPN Client and browsing the internet

Unanswered Question
Apr 23rd, 2008

Hi am running Windows Vista enterprise and cisco VPN client version to connect to my Corporate office. When my VPN cleint is connected to the corporate network I can not browse the internet if am not connected I have no problem browsing the internet. Now if I establish the VPN connection from a Windows XP computer using the same version of the VPN client I can connect to the corporate network and browse the internet without a problem.

What is cauing this behaviour on my windows Vista notebook and how can I solve it so that I am able to connect to the corporate network and browse the internet at the same time.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
mr_vaughn Thu, 05/01/2008 - 14:48

I have the same exact issue.

Vista 32bit Enterprise SP1

Cisco VPN Client

I have found that there is an additonal default route added to the route table

if you do the following it gets both VPN and the Internet to work.

open cmd

route delete

route add mask "your default gateway" metric 1

replace "your default gateway" with the IP of your LAN router.

This reminds me of the days of Microsoft PPTP tunnels

mr_vaughn Thu, 05/01/2008 - 14:52

I have also found that 2 other Windows XP laptops work fine with the 4.8 client on the same LAN connecting to the same VPN concentrator.

Split tunnel works fine on XP Pro and on Vista once default route is changed as stated above.

This is a routing addition bug that needs to be fixed.

smburke Sat, 05/10/2008 - 04:17

It has to be a problem with the VPN client itself, as the previous version did not exhibit this behavior.

I've seen the same behavior with on both Vista (SP1) and Win2k8 server.

pixelplay Sun, 05/11/2008 - 10:33

Yeah I have the same issue on Vista Enterprise + SP1 ... the behavior looks like following when I am connecting to one of my sites Cisco VPN doesn't drop the old connection (to the internet) it is drops each new one... it is really mad... the quality of this products is unacceptable for company like Cisco. It is looks like group of teenagers were writing this staff!

Hieu Cao Wed, 06/11/2008 - 13:23

I had a similar issue with Vista Home Premium edition. Remove the most recent Cisco client and install an older version fixed the issue.


mr_vaughn Wed, 06/11/2008 - 17:45

I have found that some sites do work while others do not.

It must be something with the anding and the IP addresses because DNS works fine.

I found that if i connect to the VPN and run these commands for my network my vpn works fine and internet is able to browse.

route delete

route add mask metric 1

weasleadmin Wed, 07/02/2008 - 15:37

I've had a similar problem. My issue is that I CAN browse the internet when my vpn is active (not allowed as vpn profile is not configured for local LAN access) and CANNOT ping or access any network resources.

I tried the route delete method and this does work, however in my case when I disconnect the VPN I have to disable and re-enable my wireless connection to re-create the other route was deleted.

I found an alternative solution. In my case when I ran "route print" from a command line after being connected to the VPN, the two routes for were listed in reverse in respect to the METRIC value. I opened the connection properties of both the Cisco VPN Adapter and my wireless connection and modified the metric value in the TCPIP v4 advanced properties. This way, when my vpn is active the VPN Adapter has a lower metric value than the wireless adapter.

I have experienced this issue on all of our vista clients so far. I can't tell whether this is a issue with Vista or the client. XP works great and never had a problem. It would be nice if an engineer could shed some light on why this happens.


mr_vaughn Thu, 07/31/2008 - 19:27

The new latest relaase VPN client fixed the issue so far.




This Discussion