VSS inconsistency on identical switches

Unanswered Question
Apr 24th, 2008
User Badges:

Hello !!


Wondering if anyone can shed any light on this strange problem I am having here.


I have two identical 6509 with the Sup 720-10G-3C and I tried to configured a basic VSS between both of them like the following


"Not Working Switch


switch virtual domain 5

switch 1

exit


interface port-chan 10

switch virtual link 1

no shut

exit


inter ten 5/4

channel-group 10 mode on

no shut


------------

Working Switch


switch virtual domain 5

switch 2

exit


interface port-chan 20

switch virtual link 2

no shut

exit


inter ten 5/4

channel-group 20 mode on

no shut"


after this I need to convert them from standalone to virtual switches using the "switch convert mode virtual"


one switch reboots in a virtual mode just fine but the other doesn't


the only difference between them is the working switch has "WS-C6509-E (R7000) processor (revision 1.2) with 983008K/65536K bytes of memory."


the switch that doesnt work has "cisco WS-C6509-E (R7000) processor (revision 1.4) with 983008K/65536K bytes of memory."


do you see the difference in the processor revision ?


the error i get with the switch that doesnt work is after suposedly converting the configuration, saving it and booting just at the end of the boot it does not like the new prefic of the switch before a port number like this "interface GigabitEthernet1/1/2

^

% Invalid input detected at '^' marker.

"

it outputs this error for every single port in the switch and just goes back to standalone


Does any one have any idea why this switches running the same IOS and both having a write erase and just the configuration copied up there one will boot into virtual mode and the other wont ?


thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Sushil Kumar Katre Thu, 04/24/2008 - 05:30
User Badges:
  • Gold, 750 points or more

Hi David,


I gues the switch virtual domain number should be the same on both the chassis.


Try configuring switch virtual domain 5 on the non working switch.


-> Sushil

david.mesquita Thu, 04/24/2008 - 05:40
User Badges:

I have, both switches have been configured with virtual domain number 5


I have even tried the configuration of the working switch (2) on the non working switch (1) and it still didn't work.


I don't think the problem is on the configuration but I an open for suggestions.

Sushil Kumar Katre Thu, 04/24/2008 - 06:25
User Badges:
  • Gold, 750 points or more

Hi David,


After reading your post I was laughing at myself.


The configuration whcih you have posted has the same domain.


I can't recall what part of configuration I was looking at while typing the reponse :)


Sorry for the inconvenience.


This is surely not a configuration issue.


We'll have to look at something else. What is the IOS version you are running David?


-> Sushil

david.mesquita Thu, 04/24/2008 - 06:38
User Badges:

I dont think its an IOS problem either as one of the switched boots okay into virtual mode and the other doesn't


but they are both running this IOS


Cisco IOS Software, s72033_rp Software (s72033_rp-IPSERVICESK9_WAN-M), Version 12.2(33)SXH, RELEASE SOFTWARE (fc5)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Sun 19-Aug-07 07:38 by prod_rel_team


ROM: System Bootstrap, Version 12.2(17r)SX5, RELEASE SOFTWARE (fc1)


david.mesquita Fri, 04/25/2008 - 01:44
User Badges:

I have also tried both switches with s72033-ipservices_wan-vz.122-33.SXH1.bin and still one works and the other doesn't work.


anyone ??

Sushil Kumar Katre Fri, 04/25/2008 - 02:43
User Badges:
  • Gold, 750 points or more

HI David,


I don't have any idea now, apart from comparing teh show mod output from the switches and checking the firmware version of the SUP and the Line card.


I guess you are using the 10GE Line card for interchassis connectivity.


-> Sushil

burleyman Fri, 04/25/2008 - 10:31
User Badges:
  • Blue, 1500 points or more

Try the following.....Still new to this but I think I covered everything.


switch virtual domain 5

switch mode virtual

switch 1 priority 110

switch 2 priority 100


interface Port-channel10

no switchport

no ip address

switch virtual link 1

mls qos trust cos

no mls qos channel-consistency

!

interface Port-channel20

no switchport

no ip address

switch virtual link 2

mls qos trust cos

no mls qos channel-consistency


interface TenGigabitEthernet1/5/4

no switchport

no ip address

mls qos trust cos

channel-group 1 mode on

!

interface TenGigabitEthernet1/5/5

no switchport

no ip address

mls qos trust cos

channel-group 1 mode on

interface TenGigabitEthernet2/5/4

no switchport

no ip address

mls qos trust cos

channel-group 2 mode on

!

interface TenGigabitEthernet2/5/5

no switchport

no ip address

mls qos trust cos

channel-group 2 mode on


module provision switch 1

slot 1 slot-type 147 port-type 61 number 48 virtual-slot 17

slot 4 slot-type 284 port-type 60 number 16 virtual-slot 20

slot 5 slot-type 254 port-type 31 number 2 port-type 61 number 1 port-type 60 number 2 virtual-slot 21

!

module provision switch 2

slot 1 slot-type 147 port-type 61 number 48 virtual-slot 33

slot 4 slot-type 284 port-type 60 number 16 virtual-slot 36

slot 5 slot-type 254 port-type 31 number 2 port-type 61 number 1 port-type 60 number 2 virtual-slot 37

Hope this helps,

Mike




david.mesquita Wed, 04/30/2008 - 23:53
User Badges:

hi burleyman


commands like this

"switch mode virtual

switch 1 priority 110

switch 2 priority 100 "


can only be issued after the conversion of the configuration to a VSS config which is where i am having the problem


also you can only config things with a switch/chasi/port (1/5/4) opposed to just chasi/port (5/4) after u done the conversion too so again i hit the problem when the switch boots up after the conversion


thanks for your help anyway

Hi David,


In your configuration I do not see the following:

#Set the switch ID - 1 or 2

#Note: This is an enable mode command rather than config mode


switch set switch_num 1


#Verify


switch read switch_num


This is required for the switch to properly boot into VSS mode. Part of the process for VSS is a pre-config read of information that designates the switch ID to let each member of the VSS system know who they are. If you do not include this statement one or both of the switches will not come up cleanly.


If you would like a config script/checklist that we used when setting up our two VSS nodes shoot me a message at [email protected]


Be fantastic

siskoboy2007 Fri, 04/25/2008 - 12:46
User Badges:

David, I have the exact same problem. Switch 1 will come up fine but not switch 2. Have you resolved this issue yet?

david.mesquita Wed, 04/30/2008 - 23:50
User Badges:

hi siskoboy


no i have not resolved it yet, i have opened a TAC call with cisco and we are trying to resolve it at the moment, a few emails back and forth but no resolution yet.


one of the things the guys at cisco told me to do was to check my registry was set correctly to 0x2102 which it was, but this might be your problem I don't know.


do you have different processor version like i do from one sup to the other ?

r.sharafi Mon, 07/28/2008 - 00:37
User Badges:

Hi David,


I have the same problem with the same processor version and same config register.

Fortunately I have a few more Sups around. So I tried to see if the problem is solved by replacing the Sup which did not bring up the VSL. And voila: with another sup and exact the same config and image everything is fine. I will now continue investigating what is the cause of the problem. Do you have any news from Cisco?

Regards,


Ramin

Actions

This Discussion