EIGRP network problem

Answered Question
Apr 24th, 2008

Hi

I am having a problem with a normal EIGRP routing configuration.

Router A

router eigrp 100

redistribute static

network 10.1.0.0 0.0.255.255

network 10.250.1.1 0.0.0.0

network 10.250.1.8 0.0.0.7

network 10.250.1.16 0.0.0.7

network 10.250.2.8 0.0.0.7

network 192.168.1.0 0.0.0.127

no default-information in

auto-summary

!

ip classless

Router B

router eigrp 100

redistribute static

network 10.2.1.0 0.0.0.255

network 10.250.1.16 0.0.0.7

network 10.250.2.1 0.0.0.0

network 10.250.2.8 0.0.0.7

network 10.250.2.16 0.0.0.7

network 192.168.1.0 0.0.0.127

no default-information in

auto-summary

!

ip classless

The 10.250.x.x IPs are the device interconnect IPs of 8 bit, connection to other devices and LAN. The 192.168.1.x is the subnet for WAN (Actually LAN, a VPLS network) addressing.

The LAN/VPLS connection between 192.168.1.x network is up, I can see both router as EIGRP neighbors but they don't exchange any routes. There are no routes learned from EIGRP in the routing table.

If I assign 10.250.1.x IP to the same interfaces of both routers then I see neighbors and can see learned routes in the routing table. Everything works very well when 10.250.1.x IP is used on both ends but for same physical interface/link they don't learn any routes if 192.168.1.x IP is used. What could be the reason?

Thanks

I have this problem too.
0 votes
Correct Answer by Richard Burts about 8 years 7 months ago

Kapish

Thanks for the additional information. Based on this I believe that your problem is that auto-summary is configured. Your network appears to have discontiguous subnets when the VLAN 980 is configured with the 192.168.1 addresses (some subnets on 10.0.0.0 on routerA separated from subnets of 10.0.0.0 on routerB by the 192.168.1 network). And discontiguous subnets are a problem when auto-summary is configured. When you configure VLAN 980 with network 10.250.1 then it is contiguous and the subnets are learned. If you configure no auto-summary on both routers then they should work ok with the 192.168.1 addresses.

HTH

Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Richard Burts Thu, 04/24/2008 - 10:04

Is it possible that the interfaces are configured with secondary addresses?

If not please provide more information about the interfaces and how they are configured.

HTH

Rick

kapish.mohole Thu, 04/24/2008 - 17:23

This is the IP addressing that is working right now, EIGRP is learning routes when 10.250.1.17 and 18 with 29 bit mask IP used for VLAN 980. 980 Vlan is the VPLS network. If I use 192.168.1.x/24 on both ends for 980 vlan EIGRP doesn't learn any routes, just shows neighbors.

Loop back and tunnel interfaces are for GRE as backup link, it works very well. the bandwidth on interface will determine the best path either GRE or VPLS, vlan 980 is of higher BW.

Router A

interface Tunnel0

bandwidth 10000

ip address 10.250.2.10 255.255.255.248

keepalive 1 2

tunnel source Loopback0

tunnel destination 10.250.2.1

!

interface Loopback0

ip address 10.250.1.1 255.255.255.255

!

interface GigabitEthernet0/1

switchport access vlan 980

!

interface Vlan980

bandwidth 100000

ip address 10.250.1.17 255.255.255.248

!

Router B

interface Tunnel0

bandwidth 10000

ip address 10.250.2.9 255.255.255.248

keepalive 1 2

tunnel source Loopback0

tunnel destination 10.250.1.1

!

interface Loopback0

ip address 10.250.2.1 255.255.255.255

!

interface GigabitEthernet0/1

switchport access vlan 980

!

!

interface Vlan980

bandwidth 100000

ip address 10.250.1.18 255.255.255.248

!

dosent work (keeping other inferfaces' config same) -

Router A

!

interface Vlan980

bandwidth 100000

ip address 192.168.1.10 255.255.255.0

!

Router B

!

interface Vlan980

bandwidth 100000

ip address 192.168.1.11 255.255.255.0

!

Thanks

Correct Answer
Richard Burts Fri, 04/25/2008 - 03:36

Kapish

Thanks for the additional information. Based on this I believe that your problem is that auto-summary is configured. Your network appears to have discontiguous subnets when the VLAN 980 is configured with the 192.168.1 addresses (some subnets on 10.0.0.0 on routerA separated from subnets of 10.0.0.0 on routerB by the 192.168.1 network). And discontiguous subnets are a problem when auto-summary is configured. When you configure VLAN 980 with network 10.250.1 then it is contiguous and the subnets are learned. If you configure no auto-summary on both routers then they should work ok with the 192.168.1 addresses.

HTH

Rick

kapish.mohole Fri, 04/25/2008 - 05:22

Hi, Thanks for the reply.

Thats what I was thinking of, auto-summery creating this problem. I will try it today.

Thanks

Richard Burts Sun, 04/27/2008 - 16:42

Kapish

Thanks for posting back to the forum and confirming that it was the auto-summary that was causing the problem. It helps the forum when a problem is described and a solution is suggested and it is confirmed that the solution did solve the problem.

HTH

Rick

Richard Burts Sun, 04/27/2008 - 17:48

Kapish

Thank you. You have not only posted back to the forum to confirm the problem and its solution but now you have used the rating system to indicate that your problem was resolved. Using the rating system makes it obvious to people looking at a discussion thread that they will see responses which did resolve the problem and this is very helpful for the forum.

The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum.

HTH

Rick

Actions

This Discussion