EIGRP to replace static route

Unanswered Question
Apr 24th, 2008
User Badges:

I am trying to replacing the following static route:


ip route 75.32.90.128 255.255.255.128 10.1.0.3


Here is how I tried to configure EIGRP


router eigrp 100

redistribute static

network 10.1.0.0 0.0.255.255

network 69.0.0.0

network 75.0.0.0

network 192.168.106.0

auto-summary


I am new to routing so any help would be appreciated. Thanks.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Richard Burts Thu, 04/24/2008 - 10:57
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Cyril


I am not clear about what your question really is. Your description says you want to replace the static route. Then in looking at the partial configuration I see a redistribution of static routes and I see a network statement for a network that would include the subnet of the static route. Perhaps you can clarify?


To me if we want to replace a static route I would assume that meant that we want to remove the static route and to learn that subnet dynamically from some neighbor. It is not clear in your description whether some neighbor is advertising that subnet. Perhaps you can clarify?


The static route specifies a next hop address of 10.1.0.3. I notice that there is an EIGRP network statement for 10.1.0.0. This would seem to include the interface connected to the next hop. Can you verify that this is the case? And if it is the case can you tell us whether the router at 10.10.0.3 is running EIGRP and is advertising that subnet?


I also notice that you have redistribute static. But you do not specify any default metric. Most of the time in redistributing routes into EIGRP you need to specify a default metric. Perhaps you should add a default metric to your configuration.


HTH


Rick

cjoseph23 Thu, 04/24/2008 - 11:18
User Badges:

Rick thanks for the quick response. The 10.1.0.0 network is actually a Gig interface on this same route as the 75.0.0.0 network. I have posted my config so you will be able to take a look.



Attachment: 
Richard Burts Thu, 04/24/2008 - 11:54
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Cyril


I have looked at the information that you posted and it does help to explain a few things. I notice in the information that you have several static routes with 10.1.0.3 as the next hop. From the list of EIGRP neighbors I see that you have a neighbor at 10.1.0.2 but not at 10.1.0.3. Is it correct that 10.1.0.3 is not running EIGRP?


I must confess that I still am not clear about what it is that you are attempting to accomplish. The original post talks about wanting to replace the static route. But replace it with what? Do you want to learn that subnet dynammically? If so it looks like you would need to run EIGRP on 10.1.0.3.


If that is not the solution that you are looking for then please clarify what it is that you are looking for.


HTH


Rick

cjoseph23 Thu, 04/24/2008 - 12:49
User Badges:

Rick,


10.1.0.3 is my firewall. What is happening is traffic sourced with 75.32.90.128 die at the router unless I have that static route in place. I thought that the following:


ip route 0.0.0.0 0.0.0.0 10.1.0.3


would send any sourced traffic to the firewall. It seemed redundant for me to add multiple routes to send traffic to the firewall. Ideally i would like not to use


ip route 75.32.90.128 255.255.255.128 10.1.0.3

ip route 192.168.113.0 255.255.255.0 10.1.0.3

ip route 10.0.0.0 255.255.255.0 10.1.0.3


if I don't have to. Thanks.


Cyril

Richard Burts Fri, 04/25/2008 - 04:02
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Cyril


The additional explanation is helpful. I can identify the reason why you need the static route but can not yet identify the underlying cause of the issue.


The reason that you need the static route is found in the routing table information that you posted:

D 75.0.0.0/8 is a summary, 1w1d, Null0

This is a summary route for network 75.0.0.0 and its effect is that unless you have routing information for specific subnets of 75.0.0.0 the traffic is discarded.


I am not quite clear why this summary route is produced by EIGRP. In my experience it is typically the result of a summary address configured in EIGRP. But the config that you posted does not have any summary addresses configured. Is there perhaps any part of the config that you did not post?


I would suggest that you change the configuration which currently has auto-summary under router eigrp and configure no auto-summary and see if that changes the behavior.


HTH


Rick

Richard Burts Fri, 04/25/2008 - 04:06
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Cyril


In reading my response and with further examination of the config I conclude that I was right in suggesting change from auto-summary to no auto-summary. I notice that you have a subnet of network 75 on the interface MFR1.1. The result is that EIGRP will advertise the summary of 75.0.0.0/8 out its other interfaces and will generate the 75.0.0.0/8 to null 0 in the routing table.


I am now confident that if you configure no auto-summary that you will no longer need the static route.


[edit] note that with auto-summary configured you would have discontiguous subnets where 75.32.90.128 is behind the firewall and 75.31.153.182 is on interface MFR1.1. With auto-summary configured discontiguous subnets are a problem (requiring static routes to fix) and with no auto-summary they cease to be a problem.


HTH


Rick

cjoseph23 Mon, 04/28/2008 - 09:39
User Badges:

Rick,


The no auto-summary command did the trick. I appreciate your help on this one.


Thanks,

Cyril

Richard Burts Mon, 04/28/2008 - 13:15
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Cyril


I am glad that you got your issue resolved and that my suggestion showed you the way to the solution. Thank you for using the rating system to indicate that your issue was resolved (and thanks for the rating). It makes the forum more useful when people can read about an issue and can know that there were responses which led to the resolution of the issue.


The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum.


HTH


Rick

Actions

This Discussion