pppoe over adsl is slow

Unanswered Question
m-haddad Thu, 04/24/2008 - 12:40


Try to set the MTU to 1492.

Please let me know how it goes,

alaeldien Wed, 11/26/2008 - 02:48


iam having the same scenario, just you need to check the modem ,and before that ajust the MTU in by using Dr.TCP

Hope to help


usslindstrom Wed, 11/26/2008 - 01:17

I honestly don't mean to thread-jack... But were you ever able to find a solution to this problem?

I'm experiencing the exact same issue on an 1841 w/PPPoE to an ADSL Bridge.

I've tried everything I can think of at the moment, but no-go on all counts. If we compare configs or so, we might be able to come up with a viable solution.

dlongpre Mon, 12/15/2008 - 22:10

I have the same issue on 1811 (12.4(15)T7) w/PPPoE to an ADSL Bridge modem. From the Cisco router itself, even pinging the Dialer IP is "very" slow i.e 105 ms. I "pinged extended" the router IP loopback from IP source "inside" interface and it's okay (1 ms). I tried disabled CEF and Inspect on Dialer interface, just in case, and still the same problem when pinging the Dialer IP i.e 105ms. Any idea?

Here the interfaces config:

interface FastEthernet0

description OUTSIDE Zone (To Modem ADSL)

no ip address

ip mtu 1492

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1




ST-LO#sh run int dialer0


interface Dialer0

description PPPoE (linked to Fa0)

mtu 1492

ip address negotiated

ip access-group acl-outside in

no ip unreachables

ip nat outside

ip inspect france-fw out

no ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp chap hostname xxxxxxxx

ppp chap password 0 xxxxxxx


usslindstrom Mon, 12/15/2008 - 23:56

Well, going over our 2 config's - they're almost 100% identical.


I've played with the MTU settings, and even gone as low as 800, but nothing seems to affect it.

Here is the config, and some output commands:

Here are the router specs:

Cisco 1841 (revision 7.0) with 354304K/38912K bytes of memory

Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

flash: c1841-adventerprisek9-mz.124-15.T3.bin

Running Config:

interface FastEthernet0/1

description USS_WAN

no ip address

speed 100


pppoe enable group global

pppoe-client dial-pool-number 1

no cdp enable

interface Dialer1

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1452

no ip mroute-cache

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname -----

ppp chap password -----

ppp pap sent-username ----- password -----

ppp ipcp route default


The solution that I've had to use as of current - is the have the original ISPs craptastic equipment in place, and drop the cisco router into a DMZ of their equipment.

Doing it that way allows me to get the speed up to par with what it should be, and also use most/all of the features that the Cisco router gives me (VPN, etc.)

Unfortunately - it's very sad that my very expensive Cisco Router and very expensive Cisco modules - can't do the basic things that a $20 over-the-counter router can do. (cough* train itself on vpi/vci etc. cough*)

And thus, a using a combination of the two (Cisco Router and ISPs) is pretty much mandatory at this point in the game.


This Discussion