×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

problem with trunk and vtp between router and switch

Answered Question
Apr 24th, 2008
User Badges:

I have a router and switch that I am trying to get setup with trunking and VTP. I believe the trunking is working but the output of some show commands makes me think otherwise. VTP is not working at all - both devices are in the same domain, using the same password but never exchange information.


Here is the router:

interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 172.18.4.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 63.x.x0.9 255.255.255.252

ip nat outside

ip virtual-reassembly

no cdp enable

!

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 20.x.x.183 255.255.255.0

ip nat outside

ip virtual-reassembly

no cdp enable

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 20.x.x.185 255.255.255.240

rate-limit output 1496000 1500000 1500000 conform-action transmit exceed-action drop

no cdp enable

!

interface FastEthernet0/0.11

encapsulation dot1Q 11

ip address 172.18.5.1 255.255.255.0

ip nat inside

ip virtual-reassembly

rate-limit input 2000000 2000000 2000000 conform-action transmit exceed-action drop

rate-limit output 2000000 2000000 2000000 conform-action transmit exceed-action drop



sh vtp status:

VTP Version : 2

Configuration Revision : 1

Maximum VLANs supported locally : 256

Number of existing VLANs : 9

VTP Operating Mode : Server

VTP Domain Name : TEST

VTP Pruning Mode : Enabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0xBA 0xCB 0x9F 0xE0 0xC2 0x5D 0x21 0x3C


sh int trunk: <blank>



Here is the switch:

interface FastEthernet0

switchport mode trunk

duplex full

speed 100

!

interface FastEthernet1

switchport access vlan 2

!

interface FastEthernet2

switchport access vlan 3

!

interface Vlan1

ip address 172.18.4.2 255.255.255.0



sh vtp status:

VTP Version : 2

Configuration Revision : 0

Maximum VLANs supported locally : 8

Number of existing VLANs : 7

VTP Operating Mode : Client

VTP Domain Name : TEST

VTP Pruning Mode : Enabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0xDA 0xCA 0x50 0xF0 0xAA 0x36 0xBF 0x67




sh int trunk:

Port Mode Encapsulation Status Native vlan

Fa0 on 802.1q trunking 1


Port Vlans allowed on trunk

Fa0 1-4094


Port Vlans allowed and active in management domain

Fa0 1-3


Port Vlans in spanning tree forwarding state and not pruned

Fa0 1-3

Correct Answer by glen.grant about 9 years 4 months ago

There is no vtp between a router and a switch when trunking unless the router has one of the multi port WIc switching modules installed . The commands are there if you have that installed but if you don't it really doesn't have any meaning. Between a router and a switch you are just forcing a trunk on and no vtp is used.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
glen.grant Thu, 04/24/2008 - 15:41
User Badges:
  • Purple, 4500 points or more

There is no vtp between a router and a switch when trunking unless the router has one of the multi port WIc switching modules installed . The commands are there if you have that installed but if you don't it really doesn't have any meaning. Between a router and a switch you are just forcing a trunk on and no vtp is used.

mvoss@kodiaksys.com Fri, 04/25/2008 - 07:32
User Badges:

I just put in a 9 port POE switch WIC and there is still no VTP communication. It's just a router and switch setup so it's not that big a deal.


Any ideas why show int trunk is blank on the router?

padramas Thu, 04/24/2008 - 15:47
User Badges:
  • Cisco Employee,

Hello Michael,

Can you check whether you have correct VTP passwords on router/switch by doing a " sh vtp password "


if different you set both ends having the same password by " vtp password


[Edit] agreeing with glen, assuming that you are trying VTP on VTP supported switch modules or certain models like 7600 series

HTH

Padmanabhan

mvoss@kodiaksys.com Fri, 04/25/2008 - 06:25
User Badges:

I checked the passwords about 20 times so I know I at least have that correct. :)


Glen's answer is what I was not hoping to hear but oh well.


Thanks for the help guys.

glen.grant Fri, 04/25/2008 - 07:34
User Badges:
  • Purple, 4500 points or more

Is f0/0 part of that wic module ? If so then the setup may not be correct.

Actions

This Discussion