multicast over NAT

Unanswered Question
Apr 24th, 2008

We need to get mcast data from our provider but in order to do so, we have to NAT our IP addresses. Because our switches are unable to NAT, we connected them to routers that are able to NAT. The routers in turn connect to our providers via layer 2 over the switches.

The "sh ip mroute" from the switches show the switches attempting to join the mcast group but the routers are not joining the mcast groups from the provider. What am I missing here? I tried "ip pim join-group x.x.x.x" from the routers interfaces and was able to join the group but only doing so. But that is the only way.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
didyap Wed, 04/30/2008 - 11:55

When you configure Network Address Translation (NAT) on a Cisco router, multicast sources and receivers, or Protocol Independent Multicast (PIM) entities, such as Rendezvous Points (RPs) or RP mapping agents, work on either side of the NAT router without additional configuration commands.

You must fully enable multicast on all the routers (inside, outside, and the NAT router itself).

Here is the configuration guide for the multicast which will help you:


This Discussion