DNS issues with VPN Client 5.0 on Vista

Unanswered Question
Apr 25th, 2008

Having a lot of trouble with the VPN Client on Vista. Routinely I will VPN into several different networks, and will be unable to ping by name any resource on the network. I can ping or connect to the IP address no problem.

If I hardcode the DNS server into the properties of the NIC, it works fine. What I am trying to figure out is, after making a connection the VPN (ASA in this case) -- why does my local DNS default to my local router IP, and not the customer's DNS?? Several of my machines are now acting this way.

BTW, when doing a ipconfig /all -- the VPN adapter has the correct DNS and WINS servers. They just don't get used when trying to connect to resources after the VPN connection comes up.

Any pointers welcome.

Skip

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
smalkeric Fri, 05/02/2008 - 12:40

Was there any logging on the client side or on the server side to see if the DNS settings were passed down?

evanwicklen Thu, 05/29/2008 - 16:53

I'm having the same issue. After connecting to the VPN client, I can ping local addresses on my network, but not using their dns name. I'm using Vista with a wireless connection through a Linksys router. If I manually enter my network DNS server in my wireless connection, it then works. It seems that either Vista and/or the new Cisco VPN client doesn't know how to use the DNS servers provided by the VPN connection settings from the router. And one more bit of info is that my Cisco route is an 1841.

And help would be greatly appreciated!

evanwicklen Fri, 05/30/2008 - 08:32

I wanted to add to this thread, as I've seen more problems with this client working with Vista. It seems that, if I manually set the DNS servers, things work how they should other than the speed is TERRIBLE! My connection is great, using a cable modem, but any communications via the VPN tunnel are extremely slow...

evanwicklen Fri, 05/30/2008 - 18:57

I haven't figured out the DNS issue yet, but I did figure out the slowness. Here are the commands that solved my problem:

netsh int tcp set global autotuninglevel=disabled

netsh int tcp set global rss=disabled

Although, I think it might just be the first that's needed, as I found this MS article describing the problem I was having: http://support.microsoft.com/kb/935400

If I figure out the DNS issue, I'll post back here.

r.nair Tue, 06/03/2008 - 02:59

It is related to enabling IPv6 with the VPN client installation. IPv6 had to be disabled to make it work.

evanwicklen Tue, 06/03/2008 - 06:40

I uninstalled then reinstalled the client and there was no option to disable IPv6.

Actions

This Discussion