Three point trunk and link throughput

Unanswered Question
Apr 26th, 2008

I have VPLS link connecting three locations.

Location A - vlan 100 for data

Location B - Vlan 100 for data, vlan 200 for internet (both going through same link/same service provider)

Location C - vlan 100 for data

For location B I have to carry both Vlans, as they come from one cable. Service provider wants data to be sent on appropriate vlans. For all three locations to communicate with each other, Vlan 100 is required, as I Location B has 2 vlans I have to use trunking so I have to use truning on other two ends (A,C) also.

Right now I could establish connection to internet and data by trunking, Though the data vlan is working I get very poor thoughput on the link -

Location B

B#sh run int gi0/1

Building configuration...

Current configuration : 149 bytes

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100,200

switchport mode trunk

duplex full

end

C can communicate B.

Location C

C#sh run int g0/1

Building configuration...

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 100

switchport mode trunk

end

Location A is as access mode, no trunking, communication is working, I can reach B and C but I get more than 50% packet drops. If I do trunking on end A, then A stops working at all.

Any idea how to make this work?

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
t814687 Sat, 04/26/2008 - 19:31

Looks like you have native VLAN mismatch. Make sure you have same native vlan on all the trunk ports.

-serg

Actions

This Discussion