Duplication with Router Virtual Mac-Address

Unanswered Question
Apr 27th, 2008


We have recently installed a Microsoft Exchange server with Microsoft Clustering service enabled after that we have configured Intel/dell based NIC Teaming on a dell server since then we are facing problems the entire WAN goes down we dont find any problem in Routers or switches log but on checking the log of the server we find that which is the virtual ip address of the server is conflicting with the MAC adress of the Core Router 00:00:0C:07:AC:00 this is virtual MAC address of HSRp we were advised it is a switch problem but now we have replaced the switch even now once the server is braught up same situation occurs can some one please help us out our service provider has again advised it is a Cisco incompatibility of of teaming

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Edison Ortiz Sun, 04/27/2008 - 07:39

If you are unable to modify the MAC Address on the Clustering service (00:00:0C:07:AC:00), then you can modify the MAC Address on the HSRP VIP by changing the group.

For instance, here is the output from a default configuration:

(config-if)#do show stand | i Active virtual

Active virtual MAC address is 0000.0c07.ac00

Now, if I were to change the standby group:

Rack1R1(config-if)#no standby ip

Rack1R1(config-if)#standby 1 ip

*Apr 4 01:53:20.383: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 0 state Active -> Disabled

Rack1R1(config-if)#do show stand | i Active virtual

Active virtual MAC address is 0000.0c07.ac01

You can see the virtual MAC Address has changed.




faisal_ghaus Sun, 04/27/2008 - 20:55


Thankyou very much for your response we have already tried the solution what we are facing off and on this problem occur and this is due to some thing wrong with the teaming.

I have posted the same email to other forum I have got the following solution for the problem .Can you please advise will this help


The problem was the switch configuration:

I assigned the LACP team to the channel-1, same used as VLAN1(regular switch ports), I just assigned the 5 lacp ports to the channel-2 of the switch and named it as TEAM#0 in order to identify it and it just work now!! the connection is always up and intel PROSET sofware show all interfaces of the team as Active!

this is what i did in the dell switch config:

interface port-channel 2

description TEAM#0


port jumbo-frame

interface ethernet g20

channel-group 2 mode auto


interface ethernet g21

channel-group 2 mode auto


interface ethernet g22

channel-group 2 mode auto


interface ethernet g23

channel-group 2 mode auto


interface ethernet g24

channel-group 2 mode auto



Edison Ortiz Mon, 04/28/2008 - 04:26

Not sure if the portion of the above config came from a Cisco switch, but the mode used above for the 'teaming' is not LACP.

In a cisco switch, to active LACP you must use channel-group 2 mode active

You use 'auto mode' when connecting to a PAgP peer.




This Discussion