InterVlan Routing and LAN WAN Routing in a single Router

Unanswered Question
Apr 28th, 2008

Hi

Is it possible two configure Inter VLAN Routing ( Router on a Stick ) and LAN WAN Routing in a single Router.

Pls Help

Anish N

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.8 (9 ratings)
Loading.
Jon Marshall Mon, 04/28/2008 - 03:24

Anish

Perfectly possible depending on the interfaces/modules you have available on the router.

So if you had a switch module you could configure L3 SVI's for the vlans and allocate ports into the relevant vlans. If you simply have WAN interfaces eg. serial/ATM, and ethernet interfaces you can run dot1q trunking on one of yoour ethernet interfaces.

Perhaps if you gave some more details.

Jon

anish_naw Mon, 04/28/2008 - 04:01

Hi Jon,

Thanks for the reply.

We have got a Cisco 3824 router, one 1721 Router, Cisco 3750 Switch, Cisco 2950 Switch, and some Unmanaged switches.

First I am creating a test enviornment then will configure and switchover the existing network.

I had configured two Vlans in 3750 ( Vlan100 & Vlan 101), Configured one port as a trunk which is connected to the G0/0 interface of the 3800 Router. I configured the subinterfaces in 3800 router with encapsulation dot1q, now my LAN part works fine, but now I am unable to get into the router and the same i from th router.

Pls guide me with steps to configure the outer and switch.

Thank you once again

Regards

Anish

Jon Marshall Mon, 04/28/2008 - 04:06

Anish

A different way to approach this is to use the 3750 for inter-vlan routing and the 3800 router for WAN routing. To do this

1) Configure L3 SVI interfaces on your 3750 eg.

int vlan 100

ip address

int vlan 101

ip address

Then use a /30 P2P link to connect the 3750 to the 3800 eg.

3750

int gi0/1/1

no switchport

ip address 192.168.5.1 255.255.255.252

3800

int gi0/0

ip address 192.168.5.2 255.255.255.252

Then you can either use static routing to route between your 3750 and 3800 or run a routing protocol depending on which IOS feature set you have on your 3750.

Do you see any reason why you could not do this ?

Jon

anish_naw Mon, 04/28/2008 - 04:16

Hi Jon,

Thanks for the Update, I have checked that and it is working also.

But with this config the IP address of the router will change from the current one. As per the Company's IT Policy adopted here the IP address of the Router is fixed and it cannot be changed under ny circumstances.

Thats why I m trying to do the InterVlan and the LAN WAN Routing in the same Router ( 3800).

Pls help

Thank you once again

Regards

Anish

Jon Marshall Mon, 04/28/2008 - 04:21

Anish

Slightly confused. Which is the LAN interface on your router and which is the WAN interface.

You say you cannot change the IP address but do you mean the LAN or WAN interface. Surely by doing subinterfaces you are changing the IP address(es) on the LAN interface. This is the interface i am talking about. You do not need to modify the WAN interface.

If this is still unclear could you post configs of router and 3750.

Jon

anish_naw Mon, 04/28/2008 - 04:26

Hi Jon,

Sorry for the confusion,

I was talking about the LAN Interface the IP of which cannot be changed.

Regards

Anish

Jon Marshall Mon, 04/28/2008 - 04:30

Anish

The LAN interface has at 2 ip addresses yes ? ie.

int gi0/0.100

encapsulation dot1q 100

ip address

int gi0/0.101

encapsulation dot1q 101

ip address

Are you saying from the switch you cannot ping the router ?

Do you a vlan interface on the switch for management ?. That vlan interface will have to be in either vlan 100 or vlan 101 unless you have more subinterfaces on your 3800 lan interface.

And the "ip default-gateway ...." on the switch should be set to the corresponding subinterface IP address for the vlan.

Jon

anish_naw Mon, 04/28/2008 - 05:05

Hi jon,

Configured Sub-interfaces in the router and gave IP as per the VLANs, but as soon as i configured the sub interfaces the WAN stopped working but from my PC's and the Switch Iam able to ping the Router also from Router I am able to Ping the switch and the PC's. The Router has EIGRP configured.

Is that creating a problem.

As the router is online and connected to the branch offices I have to reverse back the changes after testing.

Regards

Anish

Jon Marshall Mon, 04/28/2008 - 05:06

Anish

Could you be more specific when you say the WAN stopped working. And when it did work what was the configuration on the lan interface.

If you could post configs that might help.

Jon

anish_naw Mon, 04/28/2008 - 05:21

hi jon,

The config is as below

interface GigabitEthernet0/0

no ip address

interface GigabitEthernet0/0.1

encapsulation dot1q

ip address 10.206.24.1 255.255.255.0

no shut

interface GigabitEthernet0/0.2

encapsulation dot1q

ip address 10.206.25.2 255.255.255.0

no shut

and this interface is connected to the Gigabitethernet 1/0/23 of the 3750 which is configured as a trunk port

pls find attached the config of the switch.

For Router I will have to take permission from the concerned person and will be posting it to you

Thanks and regards

Anish

Jon Marshall Mon, 04/28/2008 - 05:26

Anish

Firstly you don't need the vlan 101 interface in your 3750 switch config as you are not routing on this switch.

Secondly you don't need the EIGRP config on the 3750 if you are not using it for routing.

Your client PC's should have their default-gateways set to the subinterface addresses on the 3800 router and not the vlan interfaces on the 3750.

Secondly i presume when you posted the config above you missed the last bit off

interface GigabitEthernet0/0.1

encapsulation dot1q

ip address 10.206.24.1 255.255.255.0

no shut

ie. encapsulation dot1q should read "encapsulation dot1q 100"

Jon

Jon Marshall Mon, 04/28/2008 - 06:05

Anish

Before you configured subinterfaces what was the IP address on gi0/0 ?

All your serial connections have "ip unnumbered gi0/0" under them but you don't have an address on gi0/0 after you configure the subinterfaces.

Jon

anish_naw Mon, 04/28/2008 - 06:08

hi jon,

The IP address on the Gi0/0 was 10.206.24.1 255.255.255.0

Anish

Jon Marshall Mon, 04/28/2008 - 06:13

Anish

Try changing "ip unnumbered gi0/0" under your serial interfaces to "ip unnumbered gi0/0.1"

Jon

anish_naw Mon, 04/28/2008 - 06:19

Thanks jon,

It is not possible for me to make changes in the router as the office is closed. I will make the changes tomorrow morning, and let you know the result.

Anish

anish_naw Mon, 04/28/2008 - 06:06

Dear Jon,

Thanks for your kind support.

Sorry, I have to leave now, as the office is closed now, Can you pls post the timing of your availability for tomorrow.

Thank you once again for your kind support.

Anish

mahmoodmkl Mon, 04/28/2008 - 04:08

Hi

I would like to suggest why dnot u use u r 3750 for intervlan routing.

From where u r trying to get in to the router.?

If from any port on the switch check the config of the switch and ur default-gateway should be sub-interface of the router.

Thanks

Mahmood

Actions

This Discussion