Strange EIGRP/GRE issue

Unanswered Question
Apr 28th, 2008

I have 2 3825 routers and have configured GRE+ EIGRP. I have 2 tunnels one going to loctnA and the other to loctnB. The GRE tunnel to loctnA is pefect. There is a lot of latency on the loctnB GRE tunnel. The end to end ping to the physical interace results in a avg latency of 4 msec, whereas ping to the tunnel interface reseults on 110 msec.

Any leads?

-Sai.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
guruprasadr Mon, 04/28/2008 - 04:03

HI Sai, [Pls Rate if HELPS]

What is the "Tunnel Mode" configured on the Tunnel Interface.

If Tunnel Mode as "ipip" is configured means, remove the same and try. I have experienced the smiliar issue and after doing a same it worked properly.

Also, redo the configuration of EIGRP on either side for Location B. This will something look like a propability try but have experienced several such cases with EIGRP and after redo of config it has worked.

Pls Rate if HELPS

Best Regards,

Guru Prasad R

saimbt Mon, 04/28/2008 - 04:27

Hi Guru,

everyting is default there is no ipip configured.

saimbt Mon, 04/28/2008 - 05:03

Tunnel1 is having the issue.

interface Tunnel0

bandwidth 6000

ip address 10.254.82.70 255.255.255.252

ip mtu 1420

ip tcp adjust-mss 1380

load-interval 30

delay 1

keepalive 10 3

tunnel source 10.254.82.126

tunnel destination 10.254.82.66

!

interface Tunnel1

bandwidth 6000

ip address 10.254.83.1 255.255.255.252

ip tcp adjust-mss 1380

load-interval 30

delay 1

qos pre-classify

keepalive 10 3

tunnel source 10.254.82.58

tunnel destination 10.254.82.57

!

!

interface FastEthernet1/0

ip address 10.254.82.126 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip accounting output-packets

ip flow ingress

ip flow egress

ip route-cache flow

no ip mroute-cache

load-interval 30

duplex full

speed 100

no cdp enable

!

interface FastEthernet1/1

bandwidth 6000

ip address 10.254.82.58 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

no ip mroute-cache

delay 1

duplex full

speed 100

no cdp enable

!

router eigrp

redistribute static

network 10.30.1.0 0.0.0.255

network 10.254.82.60 0.0.0.3

network 10.254.82.68 0.0.0.3

network 10.254.83.0 0.0.0.3

no auto-summary

!

router bgp

no synchronization

bgp log-neighbor-changes

neighbor 10.254.82.125 remote-as

no auto-summary

!

ip classless

ip route 10.30.0.0 255.255.0.0 10.30.1.254

ip route 10.108.32.0 255.255.240.0 10.30.1.254

ip route 10.254.32.176 255.255.255.240 10.30.1.254

ip route 172.21.167.0 255.255.255.0 10.30.1.254

jamesfang98 Mon, 04/28/2008 - 06:20

MTU mismatch may cause the issue since it will cause many more traffic fragmentations.

I saw you have "ip mtu 1420" setup in Tunnel0 why not in Tunnel1? Any history reason?

I would suggest to configure same in Tunnel1 and give it try.

Or, use 'tunnel path-mtu-discovery' in Tunnel1 for its to do automatically detect proper MTU for end-2-end trffic flow.

Please let me know the result and rate it.

Actions

This Discussion