Software Emulation Exception

Unanswered Question


The cisco router 1720 kept restarting itself this morning. When i log in to the console, it show me the message below:

*** Software Emulation Exception ***

PC = 0x80c60000, Vector = 0x1000, SP = 0x80004ba4

monitor: command "" aborted due to exception

May i know what is this regarding about?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Richard Burts Mon, 04/28/2008 - 07:06


Some additional information may be useful in trying to understand what is the problem. Is this a router that has been running for a time or is it a fairly new install? Have any significant changes been made to it recently (different version of code installed, config changes, etc)? What version of code is it running.

Based on what we have so far, my first guess is that there is a software problem. If you have a CCO login with sufficient privilege you might be able to take the error codes and input them to the output interpreter and get some insight into the problem. If this router is covered under a maintenance contract it would be good to open a case with Cisco TAC about this.



Richard Burts Tue, 04/29/2008 - 03:37


If that router has been running for 5 years, and especially assuming that it has been running the same code for that time, then it seems not likely that you have encountered a bug in the code (which would have been my first guess about the problem).

Upgrading the firmware is a problem since that requires a maintenance contract.

If it boots into rommon or you can get it to rommon by power cycling the router and pressing the break key as it starts its boot process, then you could change the config register to 0x2142 which has the efect of resetting everything to factory default. That might help.

You might also try powering down the router, disconnecting all network connections, if there are any network modules remove them, and power up and see if it boots without anything connected. If it does replace modules one at a time and reconnect network connections one at a time and see if there is something that causes this problem.




This Discussion