CME - stripping a prefix digit

Answered Question
Apr 28th, 2008

Hello. I'm having a small dial-peer issue for outbound international calls in CME. The dial-peer is as follows:


dial-peer voice 5 pots

destination-pattern 9011T

port 0/1/0:23

forward-digits 11

prefix 011


You can see off the bat that the number of digits i'm forwarding (11) doesn't cover all international numbers...some have 12, 13, 14, etc. I tried forwarding all the digits and removing the "prefix 011" statement, but then telco was getting the "9" prefix users are dialing, causing the call the fail. My workaround so far was creating a dial-peer for all the major country codes we're using, then passing the proper number of digits. This isn't pretty and is a big headache.


So, what I need to figure out is how to have a single international dial-peer (9011T) and pass all but the "9" to telco.


(my other option is to ask users to stop dialing "9" for international calls and change the match string, but that wouldn't be preferred).


Any help would be greatly appreciated!


Thanks,

Jad

Correct Answer by Brandon Buffin about 8 years 10 months ago

Jad,

Type the command "default forward-digits".


Brandon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Brandon Buffin Mon, 04/28/2008 - 12:36

Jad,

Just remove the "forward-digits 11" command from this dial peer. With a POTS dial peer, explicitly matched digits are discarded. So, in this case 9011 will be discarded. The "prefix 011" will add 011 back to the rest of the digits.


Hope this helps. If so, please rate the post.


Brandon

jelzein Mon, 04/28/2008 - 12:46

Brandon, that's for the response. That is one of the first things I tried. Unfortunately, if I do a "no forward digits 11", it automatically populated it with "forward-digits 0". Then the only thing being passed is the prefix (011).


Jad

Actions

This Discussion