ciscoworks LMS show license error

Unanswered Question
Apr 28th, 2008

hi

i am using LMS 2.5 and i did the fresh installation. after a few days running, LMS started showing license server error and i can't go into any of the module and they are all saying that cannot communicate with license server/service. but the license service is starting normally when i look at CS > admin > processes. any help? thank.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 04/28/2008 - 17:16

The license.log and Tomcat stdout.log might have additional errors. What happened on the server around the time this stopped working?

thetnaing00 Mon, 04/28/2008 - 19:07

the server is running normally before happening this. one morning, we tried to open up RME and generate the syslog report and the error came up just like that.

thetnaing00 Tue, 04/29/2008 - 21:51

please see the following for the output.


C:\>pdreg -l LicenseServer

Process = LicenseServer

Path = d:\PROGRA~1\CSCOpx\bin\cwjava.exe

Flags = -DNMSROOT=d:\PROGRA~1\CSCOpx -cp:p lib\classpath,objects

\log4j\1.1.3\log4j.jar,lib\classpath\License.jar -cw:jre MDC\jre com.cisco.nm.li

cense.server.LicenseServer

Startup = Started automatically at boot.

Dependencies = Not applicable

thetnaing00 Sun, 05/04/2008 - 22:15

hi guys,


any update for this or there is no solution for this. thanks.


Joe Clarke Mon, 05/05/2008 - 10:41

This looks correct, but there appears to be an issue starting this VM. Try running this command from a DOS prompt:


D:\progra~1\cscopx\bin\cwjava -cw d:\progra~1\cscopx -DNMSROOT=d:\PROGRA~1\CSCOpx -cp:p lib\classpath;objects\log4j\1.1.3\log4j.jar;lib\classpath\License.jar -cw:jre MDC\jre com.cisco.nm.license.server.LicenseServer


The command should be run all on one line. NOTE: There is a space between "MDC\jre" and "com.cisco.nm.license.server.LicenseServer".

thetnaing00 Mon, 05/05/2008 - 19:18

hi,

the following is the result of the command.


[Tue May 06 10:39:13 SGT 2008] Property file d:/PROGRA~1/CSCOpx\objects\licenses

\log4j-license.properties


i also attach the properties file. thanks,



Joe Clarke Mon, 05/05/2008 - 21:05

If running it manually works, then this could mean an issue with the environment. Try running these commands:


set NMSROOT=D:\progra~1\cscopx


D:\progra~1\cscopx\bin\cwjava -DNMSROOT=d:\PROGRA~1\CSCOpx -cp:p lib\classpath;objects\log4j\1.1.3\log4j.jar;lib\classpath\License.jar -cw:jre MDC\jre com.cisco.nm.license.server.LicenseServer

thetnaing00 Wed, 05/07/2008 - 22:53

hi,


the following is the result when i run the command.


C:\>set NMSROOT=D:\progra~1\cscopx


C:\>D:\progra~1\cscopx\bin\cwjava -DNMSROOT=d:\PROGRA~1\CSCOpx -cp:p lib\classpa

th;objects\log4j\1.1.3\log4j.jar;lib\classpath\License.jar -cw:jre MDC\jre com.c

isco.nm.license.server.LicenseServer

Unable to launch JVM

C:\>

thanks.

Joe Clarke Thu, 05/08/2008 - 21:40

This could point to a problem with your installation. Looking at the code, I can't see how this situation could happen given that running with the -cw option works. I suggest you open a TAC service request so more analysis can be done.

Actions

This Discussion